[bug#75416] gnu: python-resolvelib: Update to 1.1.0.

Message ID b13db03b8b42c73340194968195235a593d80081.1736224430.git.lockbox@struct.foo
State New
Headers
Series [bug#75416] gnu: python-resolvelib: Update to 1.1.0. |

Commit Message

Jordan Moore Jan. 7, 2025, 4:33 a.m. UTC
  * gnu/packages/python-xyz.scm (python-resolvelib): Update to 1.1.0.

Change-Id: I7108f2618fdb93ee453171be0ae5f9581271eff3
---
 gnu/packages/python-xyz.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: 329daafcc3c798dd180fd98ff757452e3e016235
  

Comments

Jordan Moore Jan. 7, 2025, 4:53 a.m. UTC | #1
This is necessary to get modern ansible working, still need to get it [ansible] passing tests though, so i submitted this package solo since it's just a leaf package
  
Jordan Moore Jan. 7, 2025, 10:14 p.m. UTC | #2
close 75416
quit

this package is too new for pypi's ansible (perfectly fine for git tree ansible). I'll send a new series that updates them together.

Jordan Moore wrote:
> This is necessary to get modern ansible working, still need to get it [ansible] passing tests though, so i submitted this package solo since it's just a leaf package
  
jgart Jan. 9, 2025, 9:42 p.m. UTC | #3
Hi, this is applied. Thanks. I thought I had closed this issue ;()

I also updated debops to work with this version of resolvelib.

Feel free to reopen or create a new ticket if there's more to do on this.
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d4893e9b53..6dd01a37ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16636,7 +16636,7 @@  (define-public python-commentjson
 (define-public python-resolvelib
   (package
     (name "python-resolvelib")
-    (version "0.7.1")
+    (version "1.1.0")
     (source
      (origin
        ;; Tests are missing from the PyPI release.
@@ -16647,8 +16647,8 @@  (define-public python-resolvelib
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1fqz75riagizihvf4j7wc3zjw6kmg1dd8sf49aszyml105kb33n8"))))
-    (build-system python-build-system)
+         "0pw99897mm2y7pa2g35z0f7vcmgh42xglz5szbrvigczvwa605sh"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -16658,7 +16658,7 @@  (define-public python-resolvelib
                (add-installed-pythonpath inputs outputs)
                (invoke "pytest")))))))
     (native-inputs
-     (list python-commentjson python-packaging python-pytest))
+     (list python-packaging python-pytest python-setuptools python-wheel))
     (home-page "https://github.com/sarugaku/resolvelib")
     (synopsis "Abstract dependencies resolver")
     (description "The ResolveLib library provides a @code{Resolver} class that