diff mbox series

[bug#66388] gnu: Add python-salib.

Message ID b10e6dc6a56ce41814e00a1080ca0ede46bb4ee9.1696680123.git.monego@posteo.net
State New
Headers show
Series [bug#66388] gnu: Add python-salib. | expand

Commit Message

Vinicius Monego Oct. 7, 2023, 12:08 p.m. UTC
* gnu/packages/python-science.scm (python-salib): New variable.
---
 gnu/packages/python-science.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 6d5a75c70e32f563f0ec6bbaf65596c15c6ac10f

Comments

Ludovic Courtès Oct. 23, 2023, 9:52 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> skribis:

> * gnu/packages/python-science.scm (python-salib): New variable.

LGTM!
Vinicius Monego Nov. 3, 2023, 10:45 p.m. UTC | #2
Em 23/10/2023 18:52, Ludovic Courtès escreveu:
> Vinicius Monego <monego@posteo.net> skribis:
>
>> * gnu/packages/python-science.scm (python-salib): New variable.
> LGTM!


Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 2dad8a2537..0916eafcb7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2050,6 +2050,33 @@  (define-public python-vaex-core
 tabular datasets.  This package provides the core modules of Vaex.")
     (license license:expat)))
 
+(define-public python-salib
+  (package
+    (name "python-salib")
+    (version "1.4.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/SALib/SALib")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "18xfyzircsx2q2lmfc9lxb6xvkxicnc83qzghd7df1jsprr5ymch"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-matplotlib
+                             python-multiprocess
+                             python-numpy
+                             python-pandas
+                             python-scipy))
+    (native-inputs (list python-hatchling python-pytest python-pytest-cov))
+    (home-page "https://salib.readthedocs.io/en/latest/")
+    (synopsis "Tools for global sensitivity analysis")
+    (description "SALib provides tools for global sensitivity analysis.  It
+contains Sobol', Morris, FAST, DGSM, PAWN, HDMR, Moment Independent and
+fractional factorial methods.")
+    (license license:expat)))
+
 (define-public python-pylems
   (package
     (name "python-pylems")