diff mbox series

[bug#47615,9/9] gnu: nss: Skip tests on powerpc-linux.

Message ID b0b76cdac4e9147105b1613fbb69707b8de5366a.1617711307.git.efraim@flashner.co.il
State Accepted
Headers show
Series Add 32-bit powerpc support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner April 6, 2021, 12:32 p.m. UTC
* gnu/packages/nss.scm (nss)[arguments]: Skip tests on powerpc-linux.
---
 gnu/packages/nss.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

Vincent Legoll April 6, 2021, 5 p.m. UTC | #1
Hello,

On Tue, Apr 6, 2021 at 2:44 PM Efraim Flashner <efraim@flashner.co.il> wrote:
> +         ;; Tests on powerpc-linux take forever and fail sporatically.

s/sporatically/sporadically/
Efraim Flashner April 6, 2021, 7:18 p.m. UTC | #2
On Tue, Apr 06, 2021 at 07:00:50PM +0200, Vincent Legoll wrote:
> Hello,
> 
> On Tue, Apr 6, 2021 at 2:44 PM Efraim Flashner <efraim@flashner.co.il> wrote:
> > +         ;; Tests on powerpc-linux take forever and fail sporatically.
> 
> s/sporatically/sporadically/
> 

Not going to lie, spelling is hard. I normally have spell check turned
off for scheme files.
Vincent Legoll April 6, 2021, 10:31 p.m. UTC | #3
On Tue, Apr 6, 2021 at 9:18 PM Efraim Flashner <efraim@flashner.co.il> wrote:
> On Tue, Apr 06, 2021 at 07:00:50PM +0200, Vincent Legoll wrote:
> > s/sporatically/sporadically/
>
> Not going to lie, spelling is hard. I normally have spell check turned
> off for scheme files.

But you *are* lying, you have the guile spell-(and-syntax-)checker enabled
for all your scheme files, and it is a picky one... ;-)
diff mbox series

Patch

diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index e054363e9f..954a1d3b80 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -1,7 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
@@ -109,7 +109,10 @@  in the Mozilla clients.")
        ;; Parallel builds are not supported (see:
        ;; https://bugzilla.mozilla.org/show_bug.cgi?id=1640328).
        `(#:parallel-build? #f
-         #:tests? #t                   ;requires at least one hour to run
+         ;; Tests on powerpc-linux take forever and fail sporatically.
+         #:tests? ,(if (string=? "powerpc-linux" (or (%current-system)
+                                                     (%current-target-system)))
+                     '#f '#t)
          #:make-flags
          (let* ((out (assoc-ref %outputs "out"))
                 (nspr (string-append (assoc-ref %build-inputs "nspr")))