diff mbox series

[bug#73184,2/5] gnu: Add go-github-com-philhofer-fwd.

Message ID b080793c762e4c6abcc128f2e10c80fc630e0c87.1726082409.git.poptsov.artyom@gmail.com
State New
Headers show
Series Add some Golang libraries from the "awesome-go" list | expand

Commit Message

Artyom V. Poptsov Sept. 11, 2024, 7:23 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-philhofer-fwd): New variable.

Change-Id: I2ec89e3f6d9bd98fcde14ccb70d7373cafca38ff
---
 gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 037cef32db..89751e8fcb 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5676,6 +5676,30 @@  (define-public go-github-com-pelletier-go-toml-v2
      (list go-github-com-stretchr-testify))
     (propagated-inputs '())))
 
+(define-public go-github-com-philhofer-fwd
+  (package
+    (name "go-github-com-philhofer-fwd")
+    (version "1.1.3-0.20240612014219-fbbf4953d986")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/philhofer/fwd")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0vq27qy4sbbv316kb3jmf7np3iq6d4gq99gd53jcm2giabbqvgm5"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/philhofer/fwd"))
+    (home-page "https://github.com/philhofer/fwd")
+    (synopsis "Buffered reader/writer")
+    (description
+     "Package @code{fwd} provides a buffered reader and writer.  Each has methods
+that help improve the encoding/decoding performance of some binary protocols.")
+    (license license:expat)))
+
 (define-public go-github-com-pierrec-cmdflag
   (package
     (name "go-github-com-pierrec-cmdflag")