diff mbox series

[bug#46433] gnu: gst-plugins-base: Depend on Opus for all systems.

Message ID b080456e32312c70d4a04d75bfaffcb84878bde9.1613001715.git.leo@famulari.name
State Accepted
Headers show
Series [bug#46433] gnu: gst-plugins-base: Depend on Opus for all systems. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Feb. 11, 2021, 12:02 a.m. UTC
I tested this by building gst-plugins-base for --system=i686-linux and
also building wine.

* gnu/packages/gstreamer.scm (gst-plugins-base)[inputs]: Include opus
unconditionally.
---
 gnu/packages/gstreamer.scm | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

Comments

Leo Prikler Feb. 11, 2021, 9:43 a.m. UTC | #1
Am Mittwoch, den 10.02.2021, 19:02 -0500 schrieb Leo Famulari:
> I tested this by building gst-plugins-base for --system=i686-linux
> and
> also building wine.
I tried applying this to staging and running `./pre-inst-env guix build
--system=i686-linux gst-plugins-base`, but interestingly it just
substituted from ci.guix.gnu.org.  I suppose it's probably fine to push
this to staging, but it's still an interesting result.

Regards,
Leo
Leo Famulari Feb. 11, 2021, 7:13 p.m. UTC | #2
On Thu, Feb 11, 2021 at 10:43:45AM +0100, Leo Prikler wrote:
> I tried applying this to staging and running `./pre-inst-env guix build
> --system=i686-linux gst-plugins-base`, but interestingly it just
> substituted from ci.guix.gnu.org.  I suppose it's probably fine to push
> this to staging, but it's still an interesting result.

You got a substitute because I built the package "by hand" on
ci.guix.gnu.org.

Thanks for your review! Pushed to staging as
ea73e829d7d061d9fd8e1f672926363fe8db2a1b
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index b582585d75..0921e9ac9f 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -553,11 +553,7 @@  This package provides the core library and elements.")
        ("libXext" ,libxext)
        ("libxv" ,libxv)
        ("alsa-lib" ,alsa-lib)
-       ;; XXX Don't build with opus on 32-bit systems:
-       ;; <https://bugs.gnu.org/32360>
-       ,@(if (target-64bit?)
-             `(("opus" ,opus))
-             '())))
+       ("opus" ,opus)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ("glib:bin" ,glib "bin")