diff mbox series

[bug#62127] gnu: Syncthing: Update to 1.23.2.

Message ID b06845d34eab319b931cd7f70d104aaca60f3fa4.1678562257.git.leo@famulari.name
State New
Headers show
Series [bug#62127] gnu: Syncthing: Update to 1.23.2. | expand

Commit Message

Leo Famulari March 11, 2023, 7:17 p.m. UTC
* gnu/packages/syncthing.scm (syncthing): Update to 1.23.2.
[arguments]: Build with Go 1.20.
---
 gnu/packages/syncthing.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Leo Famulari March 24, 2023, 8:24 p.m. UTC | #1
Pushed as de84b24613afa4020f3f0553dad8e39a78d1f92c
diff mbox series

Patch

diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5f98cb56b0..2ee2ed258b 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -46,7 +46,7 @@  (define-module (gnu packages syncthing)
 (define-public syncthing
   (package
     (name "syncthing")
-    (version "1.23.0")
+    (version "1.23.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/syncthing/syncthing"
@@ -54,7 +54,7 @@  (define-public syncthing
                                   "/syncthing-source-v" version ".tar.gz"))
               (sha256
                (base32
-                "0n7438vppr8yrq8k4lsacjr48m1l0bfc2wv7rbrsc5br5bfx6rhg"))))
+                "12d1mmqr4l0xhapq72i8yjsrzma79zsv664rhyjfpajfdw7cl3ix"))))
     (build-system go-build-system)
     ;; The primary Syncthing executable goes to "out", while the auxiliary
     ;; server programs and utility tools go to "utils".  This reduces the size
@@ -64,7 +64,7 @@  (define-public syncthing
      `(#:modules ((srfi srfi-26) ; for cut
                   (guix build utils)
                   (guix build go-build-system))
-       #:go ,go-1.19
+       #:go ,go-1.20
        #:import-path "github.com/syncthing/syncthing"
        ;; We don't need to install the source code for end-user applications.
        #:install-source? #f