diff mbox series

[bug#67664] gnu: Add node-normalize-path.

Message ID b0544a7a01f2348d81fb6456c3846b7822ec9cd0.1701881451.git.hrn@posteo.net
State New
Headers show
Series [bug#67664] gnu: Add node-normalize-path. | expand

Commit Message

hrn Dec. 6, 2023, 7:11 p.m. UTC
* gnu/packages/node-xyz.scm (node-normalize-path): New variable.

Change-Id: I9afbede1f16ed1157fed95d3925b97945a73c91b
---
 gnu/packages/node-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 23627b1706af25a0a30b96b9169a3495279aff1b

Comments

Ludovic Courtès Dec. 22, 2023, 4:41 p.m. UTC | #1
Rikard Nordgren <hrn@posteo.net> skribis:

> * gnu/packages/node-xyz.scm (node-normalize-path): New variable.
>
> Change-Id: I9afbede1f16ed1157fed95d3925b97945a73c91b

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 6c16417309..9eb8595add 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -347,6 +347,35 @@  (define-public node-minimist
 Javascript.")
     (license license:expat)))
 
+(define-public node-normalize-path
+  (package
+    (name "node-normalize-path")
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jonschlinkert/normalize-path")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1l079szbgw2b9i5zx6zbwvxiivssa55a4pwfy4m7n6rdkcmsxf7f"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'patch-dependencies 'delete-dependencies
+                    (lambda _
+                      (delete-dependencies '("gulp-format-md" "mocha")))))))
+    (native-inputs (list node-minimist))
+    (home-page "https://github.com/jonschlinkert/normalize-path")
+    (synopsis "Normalize slashes in a file path")
+    (description
+     "Normalize slashes in a file path to be POSIX/Unix-like forward slashes.
+Can also condense repeated slashes to a single slash and remove trailing
+slashes, unless disabled.")
+    (license license:expat)))
+
 (define-public node-oop
   ;; No releases, last commit was February 2013.
   (let ((commit "f9d87cda0958886955c14a0a716e57021ed295dc")