diff mbox series

[bug#74114] gnu: Add r-runner.

Message ID b037d9fa187446a112b8852b272c92a64225907e.1730312458.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#74114] gnu: Add r-runner. | expand

Commit Message

Navid Afkhami Oct. 30, 2024, 6:20 p.m. UTC
* gnu/packages/cran.scm (r-runner): New variable.

Change-Id: Ie19a65368b6985cee8d5e438b33a222c18011b4d
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: d6f775c30c6f47e174f6110d1089edc6315600e4
prerequisite-patch-id: 54292fa0b75533f02730e2da44993ad685d4a432
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e5e1d25c77..212f305ba1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1689,6 +1689,30 @@  (define-public r-rpresto
 gigabytes to petabytes.")
     (license license:bsd-3)))
 
+(define-public r-runner
+  (package
+    (name "r-runner")
+    (version "0.4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "runner" version))
+       (sha256
+        (base32 "0vhqjnwcx3z3i74p26divx6palx1rwvk4jpqn64jrqlzaw9qich4"))))
+    (properties `((upstream-name . "runner")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcpp))
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=runner")
+    (synopsis "Running operations for vectors")
+    (description
+     "Lightweight library for rolling windows operations.
+Package enables full control over the window length, window lag
+and a time indices.  With a runner one can apply any R function
+on a rolling windows.  The package eases work with equally and
+unequally spaced time series.")
+    (license license:gpl2+)))
+
 (define-public r-prettydoc
   (package
     (name "r-prettydoc")