diff mbox series

[bug#68484,v2] gnu: guile-fibers: Disable failing tests on aarch64.

Message ID b02a6b5855a3c9281574ce96cb57bd383cb90593.1705520751.git.roman@burningswell.com
State New
Headers show
Series [bug#68484,v2] gnu: guile-fibers: Disable failing tests on aarch64. | expand

Commit Message

Roman Scherer Jan. 17, 2024, 7:48 p.m. UTC
* gnu/packages/guile-xyz.scm (guile-fibers): Disable failing tests on aarch64.

Change-Id: Id05b516a659f641cc7ef01efdaf6cd1f2c735800
---
 gnu/packages/guile-xyz.scm | 25 +++++++++++++++++++------
 1 file changed, 19 insertions(+), 6 deletions(-)


base-commit: 162d6a2fdd6af13272967c77347a54934ecb45e6

Comments

Ludovic Courtès Jan. 24, 2024, 10:30 p.m. UTC | #1
Hi Roman,

Roman Scherer <roman@burningswell.com> skribis:

> * gnu/packages/guile-xyz.scm (guile-fibers): Disable failing tests on aarch64.
>
> Change-Id: Id05b516a659f641cc7ef01efdaf6cd1f2c735800

I pushed a variant of this patch as
8bee6bb9aaaf35c36fe325675d1eb2daebd69c25, which avoids a rebuild on
x86_64 and makes things somewhat clearer IMO.

Thank you,
Ludo’.
Roman Scherer Jan. 24, 2024, 10:45 p.m. UTC | #2
Perfect. Thank you.

On Wed, Jan 24, 2024, 23:30 Ludovic Courtès <ludo@gnu.org> wrote:

> Hi Roman,
>
> Roman Scherer <roman@burningswell.com> skribis:
>
> > * gnu/packages/guile-xyz.scm (guile-fibers): Disable failing tests on
> aarch64.
> >
> > Change-Id: Id05b516a659f641cc7ef01efdaf6cd1f2c735800
>
> I pushed a variant of this patch as
> 8bee6bb9aaaf35c36fe325675d1eb2daebd69c25, which avoids a rebuild on
> x86_64 and makes things somewhat clearer IMO.
>
> Thank you,
> Ludo’.
>
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 77be632cc3..1db0984a04 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -823,17 +823,30 @@  (define-public guile-fibers
      (list #:make-flags
            #~(list "GUILE_AUTO_COMPILE=0")
            #:phases
-           (if (target-x86-64?)
-             #~%standard-phases
-             #~(modify-phases %standard-phases
-                 (add-before 'check 'disable-some-tests
-                   (lambda _
+           #~(modify-phases %standard-phases
+               (add-before 'check 'disable-some-tests
+                 (lambda _
+                   (unless #$(target-x86-64?)
                      ;; This test can take more than an hour on some systems.
                      (substitute* "tests/basic.scm"
                        ((".*spawn-fiber loop-to-1e4.*") ""))
+
                      ;; These tests can take more than an hour and/or segfault.
                      (substitute* "Makefile"
-                       (("tests/speedup.scm") ""))))))))
+                       (("tests/speedup.scm") "")))
+
+                   (when #$(target-aarch64?)
+                     ;; This test has issues on aarch64 systems. It passes on
+                     ;; an Apple M1, but takes a very long time on a Hetzner
+                     ;; aarch64 VM.
+                     (substitute* "tests/basic.scm"
+                       ((".*spawn-fiber-chain 5000000.*") ""))
+
+                     ;; This test has issues on aarch64 systems. It passes on
+                     ;; an Apple M1, but raises exceptions on a Hetzner
+                     ;; aarch64 VM.
+                     (substitute* "tests/channels.scm"
+                       ((".*assert-run-fibers-terminates .*pingpong.*") ""))))))))
     (native-inputs
      (list texinfo pkg-config autoconf-2.71 automake libtool
            guile-3.0            ;for 'guild compile