diff mbox series

[bug#35782] gnu: Add mallard-ducktype

Message ID alpine.DEB.2.20.1905171341010.5164@marsh.hcoop.net
State Accepted
Headers show
Series [bug#35782] gnu: Add mallard-ducktype | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Jack Hill May 17, 2019, 5:42 p.m. UTC
* gnu/packages/python-xyz.scm: (mallard-ducktype) new variable.
---
  gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
  1 file changed, 27 insertions(+)

Comments

Ludovic Courtès May 21, 2019, 2:24 p.m. UTC | #1
Hi,

Jack Hill <jackhill@jackhill.us> skribis:

> * gnu/packages/python-xyz.scm: (mallard-ducktype) new variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5322b70759..1c337e0685 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -59,6 +59,7 @@ 
  ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
  ;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
  ;;; Copyright © 2019 Sam <smbaines8@gmail.com>
+;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -3224,6 +3225,32 @@  Markdown input files, and more.  Pelican uses Jinja2 for templating
  and is very extensible.")
      (license license:agpl3+)))

+(define-public mallard-ducktype
+  (package
+    (name "mallard-ducktype")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       ;; git-reference because a proper source tarball is not available
+       ;; https://lists.gnu.org/archive/html/guix-devel/2019-05/msg00209.html
+       (uri (git-reference
+             (url "https://github.com/projectmallard/mallard-ducktype.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0crland0kmpsyjfmnflcw7gaqy5b87b6ah17cmr9d5z1kyazf54n"))))
+    (build-system python-build-system)
+    (home-page "http://projectmallard.org")
+    (synopsis "Convert Ducktype to Mallard documentation markup")
+    (description
+     "Ducktype is a lightweight syntax that can represent all the semantics
+of the Mallard XML documentation system.  Ducktype files can be converted to
+Mallard using the @command{ducktype} tool.  The yelp-tools package
+provides additional functionality on the produced Mallard documents.")
+    (license license:expat)))
+
  (define-public python-scikit-image
    (package
      (name "python-scikit-image")