diff mbox series

[bug#70514] gnu: retroarch: Fix OpenGL core and Vulkan drivers.

Message ID aff3cb8e23c19f6c03d0cc7652ee455573ecd8e7.1713793535.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#70514] gnu: retroarch: Fix OpenGL core and Vulkan drivers. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via April 22, 2024, 1:45 p.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/emulators.scm (retroarch)[arguments]: Ignore check result for
HAVE_GLSLANG_HLSL in the configure phase.

Change-Id: I3ba110b834acca25ada0e680a6bcb879b4db96f4
---
 gnu/packages/emulators.scm | 4 ++++
 1 file changed, 4 insertions(+)


base-commit: 30de2751094fa7cceeb692c656296209970d61cb
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index a935808da5..08894bd685 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1462,6 +1462,10 @@  (define-public retroarch
                  (("/usr/local/share/wayland-protocols")
                  (string-append wayland-protocols "/share/wayland-protocols")))
 
+               ;; Without HLSL, we can still enable GLSLANG and Vulkan support.
+               (substitute* "qb/config.libs.sh"
+                 (("[$]HAVE_GLSLANG_HLSL") "notcare"))
+
                ;; The configure script does not yet accept the extra arguments
                ;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
                (invoke