diff mbox series

[bug#66052,gnome-team,v4] gnu: tracker: Update to 3.6.0.

Message ID afedd96086dbc7468dd6ae3a75c0bc3d6099b03d.1694977684.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#66052,gnome-team,v4] gnu: tracker: Update to 3.6.0. | expand

Commit Message

Vivien Kraus Sept. 17, 2023, 11:29 a.m. UTC
* gnu/packages/gnome.scm (tracker): Update to 3.6.0.
[#:phases]: Add 'disable-failing-tests'.
---

> You don't need the clunky #t if you use and
True. Thank you, I did not think of that.

> but I'm sure there are other places that already have such logic to copy
> from with more idiomatic code.  Case in point: glib, which has patches for
> i686 and hurd.

I can do the same as glib, but then on x86_64, where nothing is spliced in,
the phase becomes `(lambda _)' which is a syntax error in Guile (lambdas must
have at least one item in body). I can do the "and" trick, or do as glib and
write '("Nothing to do :)") in the not-x86-32 branch of the if instead of
'(). What would be best?

In the mean time, here is the cheapest change: use the "and" trick.

 gnu/packages/gnome.scm | 19 +++++++++++++++++--
 1 file changed, 17 insertions(+), 2 deletions(-)


base-commit: e9ff5d51e3297089e66c124195e1f1b42dbded65

Comments

Liliana Marie Prikler Sept. 17, 2023, 7:51 p.m. UTC | #1
Am Sonntag, dem 17.09.2023 um 13:29 +0200 schrieb Vivien Kraus:
> * gnu/packages/gnome.scm (tracker): Update to 3.6.0.
> [#:phases]: Add 'disable-failing-tests'.
> ---
> 
> > You don't need the clunky #t if you use and
> True. Thank you, I did not think of that.
> 
> > but I'm sure there are other places that already have such logic to
> > copy from with more idiomatic code.  Case in point: glib, which has
> > patches for i686 and hurd.
> 
> I can do the same as glib, but then on x86_64, where nothing is
> spliced in, the phase becomes `(lambda _)' which is a syntax error in
> Guile (lambdas must have at least one item in body). I can do the
> "and" trick, or do as glib and write '("Nothing to do :)") in the
> not-x86-32 branch of the if instead of '(). What would be best?
And that's where my original comment with unspecified comes back in.  
If you add *unspecified* after a bunch of conditional code that may or
may not get expanded, you will at least not have an empty body :)

Also remember to use #$@ rather than #$ for reasons (allows you to use
lists rather than forcing begin everywhere).

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2077478ff2..d344d2830c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9387,7 +9387,7 @@  (define-public gnome-autoar
 (define-public tracker
   (package
     (name "tracker")
-    (version "3.5.3")
+    (version "3.6.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/tracker/"
@@ -9395,7 +9395,7 @@  (define-public tracker
                                   "tracker-" version ".tar.xz"))
               (sha256
                (base32
-                "1vi878f95a2nlvqz46ph6f05hywjb2ni0znqavhdkrbvi6qchrhl"))))
+                "1whdqidxmagsc35pmz9kcc5vs3bmvbkmnis7prnx3zxs37z2qnaj"))))
     (build-system meson-build-system)
     (arguments
      (list
@@ -9417,6 +9417,21 @@  (define-public tracker
               (substitute* "utils/trackertestutils/__main__.py"
                 (("/bin/bash")
                  (search-input-file inputs "bin/bash")))))
+          (add-after 'unpack 'disable-failing-tests
+            (lambda _
+              #$(and (target-x86-32?)
+                     ;; On 32-bit systems, the far away dates are incorrect,
+                     ;; and the floats are not parsed exactly.
+                     #~(begin
+                         (substitute*
+                             "tests/libtracker-sparql/tracker-statement-test.c"
+                           (("g_assert_cmpfloat *\\((.*), ==, ([0-9.e-]+)\\);"
+                             total actual expected)
+                            (string-append "g_assert_cmpfloat_with_epsilon ("
+                                           actual ", " expected ", 1e-12);")))
+                         (substitute* "tests/core/tracker-sparql-test.c"
+                           (("\\{ \"datetime/direct-1\", .* \\},")
+                            "/* datetime test disabled */"))))))
           (add-before 'configure 'set-shell
             (lambda _
               (setenv "SHELL" (which "bash"))))