diff mbox series

[bug#53359,1/2] gnu: tdlib: Update to 1.8.0.

Message ID af7226869b53c1f3448a24a757f0053f7f318c8a.1642591789.git.avityazev@posteo.org
State Accepted
Headers show
Series gnu: emacs-telega-server: Update to 0.8.2-2-5739794d. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev Jan. 19, 2022, 11:30 a.m. UTC
* gnu/packages/emacs-xyz.scm (tdlib): Update to 1.8.0.
---
 gnu/packages/messaging.scm | 72 +++++++++++++++++++-------------------
 1 file changed, 36 insertions(+), 36 deletions(-)

Comments

Nicolas Goaziou Jan. 19, 2022, 1:17 p.m. UTC | #1
Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

> * gnu/packages/emacs-xyz.scm (tdlib): Update to 1.8.0.

Applied. Thank you.

> +         (add-after 'unpack 'remove-failing-tests
> +           (lambda _
> +             (substitute* "test/CMakeLists.txt"
> +               ;; The test cases are compiled into a distinct binary
> +               ;; which uses mtproto.cpp to attempt to connect to
> +               ;; a remote server. Removing this file from the sources
> +               ;; list disables those specific test cases.
> +               (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
> +             #t)))))

I removed this trailing #T on your behalf.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2fe0d35a10..2feba7ac62 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2593,45 +2594,44 @@  (define-public telegram-purple
     (license license:gpl2+)))
 
 (define-public tdlib
-  (let ((commit "34ba9b21f365b8d3bdc36808c2d665ca5cd128f6"))
-    (package
-      (name "tdlib")
-      (version "1.7.10")
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/tdlib/td")
-               (commit commit)))
-         (sha256
-          (base32 "06fbdh1jypz0p1rf6xbpias4kx7xplq9xjd9vz177vwj9icq3wki"))
-         (file-name (git-file-name name version))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:tests? #t
-         #:configure-flags
-         (list "-DCMAKE_BUILD_TYPE=Release"
-               "-DTD_ENABLE_LTO=OFF")   ; FIXME: Get LTO to work.
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'remove-failing-tests
-             (lambda _
-               (substitute* "test/CMakeLists.txt"
-                 ;; The test cases are compiled into a distinct binary
-                 ;; which uses mtproto.cpp to attempt to connect to
-                 ;; a remote server. Removing this file from the sources
-                 ;; list disables those specific test cases.
-                 (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
-               #t)))))
-      (native-inputs
-       (list gperf openssl zlib php doxygen))
-      (synopsis "Cross-platform library for building Telegram clients")
-      (description "Tdlib is a cross-platform library for creating custom
+  (package
+    (name "tdlib")
+    (version "1.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tdlib/td")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "19psqpyh9a2kzfdhgqkirpif4x8pzy89phvi59dq155y30a3661q"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #t
+       #:configure-flags
+       (list "-DCMAKE_BUILD_TYPE=Release"
+             "-DTD_ENABLE_LTO=OFF")   ; FIXME: Get LTO to work.
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-failing-tests
+           (lambda _
+             (substitute* "test/CMakeLists.txt"
+               ;; The test cases are compiled into a distinct binary
+               ;; which uses mtproto.cpp to attempt to connect to
+               ;; a remote server. Removing this file from the sources
+               ;; list disables those specific test cases.
+               (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
+             #t)))))
+    (native-inputs
+     (list gperf openssl zlib php doxygen))
+    (synopsis "Cross-platform library for building Telegram clients")
+    (description "Tdlib is a cross-platform library for creating custom
 Telegram clients following the official Telegram API.  It can be easily used
 from almost any programming language with a C-FFI and features first-class
 support for high performance Telegram Bot creation.")
-      (home-page "https://core.telegram.org/tdlib")
-      (license license:boost1.0))))
+    (home-page "https://core.telegram.org/tdlib")
+    (license license:boost1.0)))
 
 (define-public purple-mm-sms
   (package