diff mbox series

[bug#70875] gnu: squirrel: Update to 3.2.

Message ID af43e1ae4ef7fb26679457a9c52a9beac9e726c6.1715419828.git.atai@atai.org
State New
Headers show
Series [bug#70875] gnu: squirrel: Update to 3.2. | expand

Commit Message

Andy Tai May 11, 2024, 9:31 a.m. UTC
* gnu/packages/squirrel.scm (squirrel): Update to 3.2.

Change-Id: Iebb19806cdb98cb15e2e739657d4f90aa6eb596e
---
 gnu/packages/squirrel.scm | 38 ++++++++++++++------------------------
 1 file changed, 14 insertions(+), 24 deletions(-)


base-commit: 703ae431f4ad28658e34675310b4fdf58685ccdd

Comments

Maxim Cournoyer June 24, 2024, 3:41 a.m. UTC | #1
Hi Andy,

Andy Tai <atai@atai.org> writes:

> * gnu/packages/squirrel.scm (squirrel): Update to 3.2.

Could you please detail the GNU ChangeLog commit message to declare what
you've done?

> Change-Id: Iebb19806cdb98cb15e2e739657d4f90aa6eb596e
> ---
>  gnu/packages/squirrel.scm | 38 ++++++++++++++------------------------
>  1 file changed, 14 insertions(+), 24 deletions(-)
>
> diff --git a/gnu/packages/squirrel.scm b/gnu/packages/squirrel.scm
> index 1b9489882f..7f959cace0 100644
> --- a/gnu/packages/squirrel.scm
> +++ b/gnu/packages/squirrel.scm
> @@ -1,5 +1,5 @@
>  ;;; GNU Guix --- Functional package management for GNU
> -;;; Copyright © 2019 Li-cheng (Andy) Tai <atai@atai.org>
> +;;; Copyright © 2019, 2024 Li-cheng (Andy) Tai <atai@atai.org>
>  ;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -22,6 +22,7 @@ (define-module (gnu packages squirrel)
>    #:use-module (gnu packages sphinx)
>    #:use-module (guix build-system cmake)
>    #:use-module (guix download)
> +  #:use-module (guix git-download)
>    #:use-module ((guix licenses) #:prefix license:)
>    #:use-module (guix build utils)
>    #:use-module (guix packages)
> @@ -30,17 +31,16 @@ (define-module (gnu packages squirrel)
>  (define-public squirrel
>    (package
>      (name "squirrel")
> -    (version "3.1")
> +    (version "3.2")
>      (source (origin
> -              (method url-fetch)
> -              (uri (string-append "mirror://sourceforge/squirrel/squirrel3/"
> -                                  "squirrel " version " stable/squirrel_"
> -                                  (string-join (string-split version #\.) "_")
> -                                  "_stable.tar.gz"))
> +              (method git-fetch)
> +               (uri (git-reference
> +                     (url "https://github.com/albertodemichelis/squirrel.git")
> +                     (commit (string-append "v" version))))
>                (file-name (string-append name "-" version ".tar.gz"))
>                (sha256
>                 (base32
> -                "1jyh1523zrrnh9swanfrda0s14mvwc9431dh07g0nx74hbxsfia8"))))
> +                "028v90k5bbcb8qwysgv6r0ycy6g920ns32i2sdq0i8hqib90ac5z"))))
>      (build-system cmake-build-system)
>      (arguments
>       '(#:configure-flags '("-DDISABLE_STATIC=ON")
> @@ -49,26 +49,16 @@ (define-public squirrel
>         (modify-phases %standard-phases
>           (add-after 'install 'install-documentation
>             (lambda* (#:key outputs #:allow-other-keys)
> -             (let* ((out (assoc-ref outputs "out"))
> +             (let* ((source (assoc-ref %build-inputs "source"))
> +                    (out (assoc-ref outputs "out"))
>                      (doc-dir (string-append out "/share/doc/squirrel")))
>                 (for-each
>                  (lambda (file)
> -                  (install-file (string-append "../squirrel3/" file) doc-dir))
> +                  (install-file (string-append source "/" file) doc-dir))
>                  '("COPYRIGHT" "HISTORY" "README"
> -                  "doc/sqstdlib3.pdf" "doc/squirrel3.pdf")))
> -             #t))
> -         (add-after 'install 'install-headers
> -           (lambda* (#:key outputs #:allow-other-keys)
> -             (let* ((out (assoc-ref outputs "out"))
> -                    (include-dir (string-append out "/include/squirrel")))
> -               (mkdir-p include-dir)
> -               (for-each
> -                (lambda (header-file)
> -                  (copy-recursively header-file
> -                                    (string-append include-dir
> -                                                   "/"
> -                                                   (basename header-file))))
> -                (find-files "../squirrel3/include")))
> +                  ;"doc/sqstdlib3.pdf" "doc/squirrel3.pdf"  ;; pdf not build out of git; TODO
> +
> +                  )))
>               #t)))))

You've left this extraneous #t here.

>      (native-inputs
>       `(("cmake" ,cmake-minimal)
>

Labels could be removed as well, perhaps in a second patch.

Could you please send a v2?
diff mbox series

Patch

diff --git a/gnu/packages/squirrel.scm b/gnu/packages/squirrel.scm
index 1b9489882f..7f959cace0 100644
--- a/gnu/packages/squirrel.scm
+++ b/gnu/packages/squirrel.scm
@@ -1,5 +1,5 @@ 
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019 Li-cheng (Andy) Tai <atai@atai.org>
+;;; Copyright © 2019, 2024 Li-cheng (Andy) Tai <atai@atai.org>
 ;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +22,7 @@  (define-module (gnu packages squirrel)
   #:use-module (gnu packages sphinx)
   #:use-module (guix build-system cmake)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build utils)
   #:use-module (guix packages)
@@ -30,17 +31,16 @@  (define-module (gnu packages squirrel)
 (define-public squirrel
   (package
     (name "squirrel")
-    (version "3.1")
+    (version "3.2")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/squirrel/squirrel3/"
-                                  "squirrel " version " stable/squirrel_"
-                                  (string-join (string-split version #\.) "_")
-                                  "_stable.tar.gz"))
+              (method git-fetch)
+               (uri (git-reference
+                     (url "https://github.com/albertodemichelis/squirrel.git")
+                     (commit (string-append "v" version))))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1jyh1523zrrnh9swanfrda0s14mvwc9431dh07g0nx74hbxsfia8"))))
+                "028v90k5bbcb8qwysgv6r0ycy6g920ns32i2sdq0i8hqib90ac5z"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags '("-DDISABLE_STATIC=ON")
@@ -49,26 +49,16 @@  (define-public squirrel
        (modify-phases %standard-phases
          (add-after 'install 'install-documentation
            (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
+             (let* ((source (assoc-ref %build-inputs "source"))
+                    (out (assoc-ref outputs "out"))
                     (doc-dir (string-append out "/share/doc/squirrel")))
                (for-each
                 (lambda (file)
-                  (install-file (string-append "../squirrel3/" file) doc-dir))
+                  (install-file (string-append source "/" file) doc-dir))
                 '("COPYRIGHT" "HISTORY" "README"
-                  "doc/sqstdlib3.pdf" "doc/squirrel3.pdf")))
-             #t))
-         (add-after 'install 'install-headers
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (include-dir (string-append out "/include/squirrel")))
-               (mkdir-p include-dir)
-               (for-each
-                (lambda (header-file)
-                  (copy-recursively header-file
-                                    (string-append include-dir
-                                                   "/"
-                                                   (basename header-file))))
-                (find-files "../squirrel3/include")))
+                  ;"doc/sqstdlib3.pdf" "doc/squirrel3.pdf"  ;; pdf not build out of git; TODO
+
+                  )))
              #t)))))
     (native-inputs
      `(("cmake" ,cmake-minimal)