[bug#75102,rust-team,8/8] gnu: rust-rustls-platform-verifier-0.3: Use variable.
Commit Message
* gnu/packages/crates-tls.scm (rust-rustls-platform-verifier-0.3):
Use rustls-platform-verifier-test-flags.
Change-Id: Ic9d0c92230057dda61158461c25aee7276aca39d
---
gnu/packages/crates-tls.scm | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)
@@ -2028,16 +2028,7 @@ (define-public rust-rustls-platform-verifier-0.3
(sha256
(base32 "145lhjn9w5khp0fn4lagaa8qqyjyhfqn2dg6llva6qyzvy5qgfxg"))))
(arguments
- `(#:cargo-test-flags
- '("--release" "--"
- "--skip=tests::verification_mock::test_verification_without_mock_root"
- "--skip=tests::verification_real_world::tests::_1password_com_valid"
- "--skip=tests::verification_real_world::tests::letsencrypt"
- "--skip=tests::verification_real_world::tests::my_1password_com_valid"
- "--skip=tests::verification_real_world::tests::my_1password_com_valid_no_stapled"
- "--skip=tests::verification_real_world::tests::unrelated_chain_not_valid_for_my_1password_com"
- "--skip=tests::verification_real_world::tests::unrelated_chain_valid_for_unrelated_domain"
- "--skip=tests::verification_real_world::tests::unrelated_domain_invalid")
+ `(#:cargo-test-flags ,rustls-platform-verifier-test-flags
#:cargo-inputs
(("rust-android-logger" ,rust-android-logger-0.13)
("rust-base64" ,rust-base64-0.22)