[bug#60992] gnu: Add emacs-paradox.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-paradox): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
base-commit: 900d33527c9286a811f064d4bb8f4a9b18d1db0b
Comments
Hello,
Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:
> * gnu/packages/emacs-xyz.scm (emacs-paradox): New variable.
Thank you.
This project is no longer maintained, and the repository is read-only.
Last release is more than 3 years old. Do you think the whole thing is
worth packaging nonetheless ?
> +(define-public emacs-paradox
> + (let ((version "2.5.5")
> + (commit "96401577ed02f433debe7604e49afd478e9eda61"))
> + (package
> + (name "emacs-paradox")
> + (version version)
You can insert version directly here. No need for a binding.
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/Malabarba/paradox")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0v9hmvq6bcr2hwlb09ldsd6pjl19ri5n2hl2bs3x52fqjj6fdzzn"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + (list emacs-seq emacs-let-alist emacs-spinner emacs-hydra))
Please order inputs alphabetically.
> + (home-page "https://github.com/Malabarba/paradox")
> + (synopsis "A modern Packages Menu")
Synopsis must not start with article "A". Also, "modern" may be vague.
> + (description
> + "Project for modernizing Emacs' Package Menu. With improved appearance,
> +mode-line information. Github integration, customizability, asynchronous
> +upgrading, and more.")
Description should consist of complete sentences.
Regards,
>dim. 22 janv. 2023 at 17:43, Nicolas Goaziou
><mail@nicolasgoaziou.fr> ...
> Hello,
>
> Cayetano Santos via Guix-patches via <guix-patches@gnu.org>
> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-paradox): New variable.
>
> Thank you.
>
> This project is no longer maintained, and the repository is
> read-only.
> Last release is more than 3 years old. Do you think the whole
> thing is
> worth packaging nonetheless ?
Good question (a few other packages, not explicitly declared as
out of maintenance, are in a similar position).
For as long as I’m concerned, this is a great piece of code which
I’ve been using frequently for a long time. Its stable and
performs well.
Regards,
C.
@@ -3125,6 +3125,33 @@ (define-public emacs-beacon
shine on top of your cursor so you know where it is.")
(license license:gpl3+)))
+(define-public emacs-paradox
+ (let ((version "2.5.5")
+ (commit "96401577ed02f433debe7604e49afd478e9eda61"))
+ (package
+ (name "emacs-paradox")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Malabarba/paradox")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v9hmvq6bcr2hwlb09ldsd6pjl19ri5n2hl2bs3x52fqjj6fdzzn"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-seq emacs-let-alist emacs-spinner emacs-hydra))
+ (home-page "https://github.com/Malabarba/paradox")
+ (synopsis "A modern Packages Menu")
+ (description
+ "Project for modernizing Emacs' Package Menu. With improved appearance,
+mode-line information. Github integration, customizability, asynchronous
+upgrading, and more.")
+ (license license:gpl2+))))
+
(define-public emacs-carp
(let ((commit "17d3d84963434233997626850195f205882bf0df")
(revision "0"))