diff mbox series

[bug#73488,games,v3,3/7] gnu: Add jg-api.

Message ID aedb7754da5780ea77bc2cbb33ddaf09f2321141.1727940344.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Add Jolly Good and some of its emulators | expand

Commit Message

Maxim Cournoyer Oct. 3, 2024, 7:25 a.m. UTC
* gnu/packages/emulators.scm (jg-api): New variable.

Change-Id: I2cd2086560f8353f8260209c4ee0f117c3615917
---

(no changes since v1)

 gnu/packages/emulators.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Maxim Cournoyer Oct. 5, 2024, 1:01 p.m. UTC | #1
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Donnerstag, dem 03.10.2024 um 16:25 +0900 schrieb Maxim Cournoyer:
>> * gnu/packages/emulators.scm (jg-api): New variable.
>> 
>> Change-Id: I2cd2086560f8353f8260209c4ee0f117c3615917
>> ---
>> 
>> (no changes since v1)
>> 
>>  gnu/packages/emulators.scm | 26 ++++++++++++++++++++++++++
>>  1 file changed, 26 insertions(+)
>> 
>> diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
>> index 50a7b67121..09e722b4f4 100644
>> --- a/gnu/packages/emulators.scm
>> +++ b/gnu/packages/emulators.scm
>> @@ -2260,6 +2260,32 @@ (define-public bsnes
>>  performance, features, and ease of use.")
>>      (license license:gpl3)))
>>  
>> +(define-public jg-api
>> +  (package
>> +    (name "jg-api")
>> +    (version "1.0.0")
>> +    (source (origin
>> +              (method git-fetch)
>> +              (uri (git-reference
>> +                    (url "https://gitlab.com/jgemu/jg")
>> +                    (commit version)))
>> +              (file-name (git-file-name name version))
>> +              (sha256
>> +               (base32
>> +               
>> "0117cvfvzhrm9fxnryhbnf9r0f8ij4ahhfqiqp5yv11bz2wcyhqh"))))
>> +    (build-system gnu-build-system)
>> +    (arguments
>> +     (list #:tests? #f
> #:tests? #f should always go with a comment.

Good call; I've added the "standard" ";no test suite" inline comment.

>> +           #:make-flags #~(list (string-append "PREFIX=" #$output))
>> +           #:phases #~(modify-phases %standard-phases
>> +                        (delete 'configure)))) ;no configure phase
> What about 'bootstrap?

No need to mess with it; it checks if a "configure" script exists (which
doesn't in this case -- it's a pure Make-based build system) and when it
doesn't it simply does:

--8<---------------cut here---------------start------------->8---
(format #t "GNU build system bootstrapping not needed~%")
--8<---------------cut here---------------end--------------->8---

-- 
Thanks,
Maxim
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 50a7b67121..09e722b4f4 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -2260,6 +2260,32 @@  (define-public bsnes
 performance, features, and ease of use.")
     (license license:gpl3)))
 
+(define-public jg-api
+  (package
+    (name "jg-api")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/jgemu/jg")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0117cvfvzhrm9fxnryhbnf9r0f8ij4ahhfqiqp5yv11bz2wcyhqh"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests? #f
+           #:make-flags #~(list (string-append "PREFIX=" #$output))
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure)))) ;no configure phase
+    (home-page "https://gitlab.com/jgemu/jg")
+    (synopsis "Emulators Plugin API")
+    (description "This package provides the Jolly Good API C and C++ headers.
+The Jolly Good API is a shared object or plugin @acronym{API, Application
+Programming Interface} for emulators.")
+    (license license:zlib)))
+
 (define-public zsnes
   (package
     (name "zsnes")