diff mbox series

[bug#48033,v2,1/2] gnu: Add perl-linux-inotify2.

Message ID aebb930ea41df54db0e9042cb2db3c40aa861927.1619699566.git.public@yoctocell.xyz
State Accepted
Headers show
Series Update public-inbox to 1.6.1 | expand

Commit Message

Xinglu Chen April 29, 2021, 12:37 p.m. UTC
* gnu/packages/perl.scm (perl-linux-inotify2): New variable.
---
 gnu/packages/perl.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 559e6ad9e0..f0750e5620 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5905,6 +5906,28 @@  writing system to another, based on national or international transliteration
 tables.  Where possible a reverse transliteration is supported.")
     (license (package-license perl))))
 
+(define-public perl-linux-inotify2
+  (package
+    (name "perl-linux-inotify2")
+    (version "2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/M/ML/MLEHMANN/Linux-Inotify2-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0crlxmaa4lsgdjm5p9ib8rdxiy70qj1s68za3q3v57v8ll6s4hfx"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-common-sense" ,perl-common-sense)))
+    (home-page "https://metacpan.org/release/Linux-Inotify2")
+    (synopsis "Scalable file change notification")
+    (description "This module implements an interface to the Linux 2.6.13 and
+later Inotify file change notification system.")
+    (license (package-license perl))))
+
 (define-public perl-list-allutils
   (package
     (name "perl-list-allutils")