diff mbox series

[bug#70081,1/2] gnu: Add pureos-archive-keyring.

Message ID aeb4408f934a4b88203b2d68bb1d502bd4414f09.1711668771.git.GNUtoo@cyberdimension.org
State New
Headers show
Series debootstrap: Add PureOS support. | expand

Commit Message

Denis 'GNUtoo' Carikli March 30, 2024, 7:55 a.m. UTC
* gnu/packages/debian.scm (pureos-archive-keyring): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Change-Id: I80af4b15c7fe20dd40358d4f676a89903060bf07
---
 gnu/packages/debian.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 1715b963a9..4aa432abfa 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -148,6 +148,31 @@  (define-public debian-ports-archive-keyring
     ;; "The keys in the keyrings don't fall under any copyright."
     (license license:public-domain)))
 
+(define-public pureos-archive-keyring
+  (package
+    (name "pureos-archive-keyring")
+    (version "2021.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://repo.puri.sm/pureos/pool/main/p/pureos-archive-keyring/"
+                    "pureos-archive-keyring_" version ".tar.xz"))
+              (sha256
+               (base32
+                "1a0d084a98bycyhbw531646rbivvlfkdk6ldshl5dy6fvzmbci0d"))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan '(("keyrings/pureos-archive-keyring.gpg"
+                         "share/keyrings/")
+                        ("keyrings/pureos-archive-removed-keys.gpg"
+                         "share/keyrings/"))))
+    (home-page "https://source.puri.sm/pureos/core/pureos-archive-keyring")
+    (synopsis "GnuPG archive keys of the Pureos archive")
+    (description "The Pureos distribution signs its packages.  This package
+contains the archive keys used for that.")
+    (license (list license:public-domain ;; the keys
+                   license:gpl2+))))     ;; see debian/copyright
+
 (define-public trisquel-keyring
   (package
     (name "trisquel-keyring")