diff mbox series

[bug#61042,v2,2/6] gnu: virglrenderer: Update to 0.10.4.

Message ID ae85e88ed2ad3b754cbd7e95bee9b29eabd060ee.1675370158.git.simon@netpanic.org
State New
Headers show
Series Upgrade spice packages | expand

Commit Message

Simon Streit Feb. 2, 2023, 9:01 p.m. UTC
* gnu/packages/spice.scm (virglrenderer): Update to 0.10.4.
  [uri]: Update source uri.
  [build-system] Change to meson-build-system.
  [inputs]: Add python; remove eudev.
  [home-page]: Update url.
---
 gnu/packages/spice.scm | 17 ++++++++---------
 1 file changed, 8 insertions(+), 9 deletions(-)

Comments

Maxim Cournoyer Feb. 25, 2023, 8:06 p.m. UTC | #1
Hi Simon,

Simon Streit <simon@netpanic.org> writes:

> * gnu/packages/spice.scm (virglrenderer): Update to 0.10.4.
>   [uri]: Update source uri.
>   [build-system] Change to meson-build-system.
>   [inputs]: Add python; remove eudev.
>   [home-page]: Update url.
> ---
>  gnu/packages/spice.scm | 17 ++++++++---------
>  1 file changed, 8 insertions(+), 9 deletions(-)
>
> diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
> index fd0ac077ed..6eb8a4bfc7 100644
> --- a/gnu/packages/spice.scm
> +++ b/gnu/packages/spice.scm
> @@ -85,25 +85,24 @@ (define-public usbredir
>  (define-public virglrenderer
>    (package
>      (name "virglrenderer")
> -    (version "0.6.0")
> +    (version "0.10.4")
>      (source (origin
>                (method url-fetch)
> -              (uri (string-append
> -                "https://www.freedesktop.org/software/virgl/"
> -                "virglrenderer-" version ".tar.bz2"))
> -              (patches (search-patches "virglrenderer-CVE-2017-6386.patch"))
> +              (uri (string-append "https://gitlab.freedesktop.org/virgl/"
> +                    name "/-/archive/" version "/" name "-" version
> +                    ".tar.gz"))

We don't use any of the 'archive' github/gitlab links as they point to
tarballs generated on the fly, which may change subtly and invalidate
the hash.  I've used git-fetch instead.

>                (sha256
>                 (base32
> -                "06kf0q4l52gzx5p63l8850hff8pmhp7xv1hk8zgx2apbw18y6jd5"))))
> -    (build-system gnu-build-system)
> +                "0522czb3nixkpwjknw3w1ifaj50686a2aj46v4r5cr0zh9cxqgys"))))
> +    (build-system meson-build-system)
>      (inputs
> -      (list libepoxy mesa eudev))
> +      (list libepoxy mesa python))

I move python to native-inputs, since no reference to it is kept.

>      (native-inputs
>        (list pkg-config))
>      (synopsis "Virtual 3D GPU library")
>      (description "A virtual 3D GPU library that enables a virtualized operating
>  system to use the host GPU to accelerate 3D rendering.")
> -    (home-page "https://virgil3d.github.io")
> +    (home-page "https://gitlab.freedesktop.org/virgl/virglrenderer")
>      (license (list license:expat license:bsd-3))))

Thanks for spotting the change of URI, I had missed it in my other
submission also updating spice and friends (sorry for missing that older
submission in the first place!).

Closing.
diff mbox series

Patch

diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index fd0ac077ed..6eb8a4bfc7 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -85,25 +85,24 @@  (define-public usbredir
 (define-public virglrenderer
   (package
     (name "virglrenderer")
-    (version "0.6.0")
+    (version "0.10.4")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                "https://www.freedesktop.org/software/virgl/"
-                "virglrenderer-" version ".tar.bz2"))
-              (patches (search-patches "virglrenderer-CVE-2017-6386.patch"))
+              (uri (string-append "https://gitlab.freedesktop.org/virgl/"
+                    name "/-/archive/" version "/" name "-" version
+                    ".tar.gz"))
               (sha256
                (base32
-                "06kf0q4l52gzx5p63l8850hff8pmhp7xv1hk8zgx2apbw18y6jd5"))))
-    (build-system gnu-build-system)
+                "0522czb3nixkpwjknw3w1ifaj50686a2aj46v4r5cr0zh9cxqgys"))))
+    (build-system meson-build-system)
     (inputs
-      (list libepoxy mesa eudev))
+      (list libepoxy mesa python))
     (native-inputs
       (list pkg-config))
     (synopsis "Virtual 3D GPU library")
     (description "A virtual 3D GPU library that enables a virtualized operating
 system to use the host GPU to accelerate 3D rendering.")
-    (home-page "https://virgil3d.github.io")
+    (home-page "https://gitlab.freedesktop.org/virgl/virglrenderer")
     (license (list license:expat license:bsd-3))))
 
 (define-public spice-protocol