diff mbox series

[bug#66372] gnu: emacs-mastodon: Update to 1.0.5.

Message ID ae7dc5ab3ec7ce032a4aa5c4afbf6a39ac045ce5.1696607091.git.me@fabionatali.com
State New
Headers show
Series [bug#66372] gnu: emacs-mastodon: Update to 1.0.5. | expand

Commit Message

Fabio Natali Oct. 6, 2023, 3:45 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.5.
---
Hi! 👋

This is to update Emacs Mastodon (mastodon.el) to 1.0.5.

Hope it looks ok. 🙏

Cheers, Fabio.


 gnu/packages/emacs-xyz.scm | 63 ++++++++++++++++++--------------------
 1 file changed, 30 insertions(+), 33 deletions(-)


base-commit: a7e6b4c98b97921ab695218f9b89be4f1ded48c9

Comments

Liliana Marie Prikler Oct. 6, 2023, 9:45 p.m. UTC | #1
Am Freitag, dem 06.10.2023 um 16:45 +0100 schrieb Fabio Natali:
> * gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.5.
> ---
> Hi! 👋
> 
> This is to update Emacs Mastodon (mastodon.el) to 1.0.5.
> 
> Hope it looks ok. 🙏
> 
> Cheers, Fabio.
> 
> 
>  gnu/packages/emacs-xyz.scm | 63 ++++++++++++++++++------------------
> --
>  1 file changed, 30 insertions(+), 33 deletions(-)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index cf1542955c..6b9f945c20 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -32827,40 +32827,37 @@ (define-public emacs-wc-mode
>      (license license:gpl3+)))
>  
>  (define-public emacs-mastodon
> -  ;; No release in ~1 year, hence this snapshot.
> -  (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
> -        (revision "1"))
> -    (package
> -      (name "emacs-mastodon")
> -      (version (git-version "1.0.0" revision commit))
> -      (source (origin
> -                (method git-fetch)
> -                (uri (git-reference
> -                      (url
> "https://codeberg.org/martianh/mastodon.el")
> -                      (commit commit)))
> -                (file-name (git-file-name name version))
> -                (sha256
> -                 (base32
> -                 
> "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
> -      (build-system emacs-build-system)
> -      (arguments
> -       (list #:phases
> -             #~(modify-phases %standard-phases
> -                 ;; Move the source files to the top level, which is
> included in
> -                 ;; the EMACSLOADPATH.
> -                 (add-after 'unpack 'move-source-files
> -                   (lambda _
> -                     (let ((el-files (find-files "./lisp"
> ".*\\.el$")))
> -                       (for-each (lambda (f)
> -                                   (rename-file f (basename f)))
> -                                 el-files)))))))
> -      (propagated-inputs
> -       (list emacs-request emacs-ts emacs-persist))
> -      (home-page "https://codeberg.org/martianh/mastodon.el")
> -      (synopsis "Emacs client for Mastodon")
> -      (description "@code{mastodon.el} is an Emacs client for
> Mastodon, the
> +  (package
> +    (name "emacs-mastodon")
> +    (version "1.0.5")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> "https://codeberg.org/martianh/mastodon.el")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "1bswv34r0x0a7va0qm6014zy1ddm4sv0l0k37d7z9r295kyz2v0s"))))
I'm getting a hash collision:

r:sha256 hash mismatch for /gnu/store/7nj10z58x8csn8q05krn23pghfcgcxjb-
emacs-mastodon-1.0.5-checkout:
  expected hash: 1bswv34r0x0a7va0qm6014zy1ddm4sv0l0k37d7z9r295kyz2v0s
  actual hash:   0zjn3v3qfr034vz0ns7s9j7n4xzzqy5xiihc307mr3f6fcjgq0xd

Looks like upstream moved the tag?
Fabio Natali Oct. 7, 2023, 12:18 a.m. UTC | #2
On 2023-10-06, 23:45 +0200, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
> I'm getting a hash collision:
[...]
> Looks like upstream moved the tag?

Hi Liliana,

Thanks for checking! True, it looks like 1.0.5 has been moved to
7d49ecba22. Updated patch just sent separately.

Cheers, Fabio.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cf1542955c..6b9f945c20 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32827,40 +32827,37 @@  (define-public emacs-wc-mode
     (license license:gpl3+)))
 
 (define-public emacs-mastodon
-  ;; No release in ~1 year, hence this snapshot.
-  (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
-        (revision "1"))
-    (package
-      (name "emacs-mastodon")
-      (version (git-version "1.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://codeberg.org/martianh/mastodon.el")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
-      (build-system emacs-build-system)
-      (arguments
-       (list #:phases
-             #~(modify-phases %standard-phases
-                 ;; Move the source files to the top level, which is included in
-                 ;; the EMACSLOADPATH.
-                 (add-after 'unpack 'move-source-files
-                   (lambda _
-                     (let ((el-files (find-files "./lisp" ".*\\.el$")))
-                       (for-each (lambda (f)
-                                   (rename-file f (basename f)))
-                                 el-files)))))))
-      (propagated-inputs
-       (list emacs-request emacs-ts emacs-persist))
-      (home-page "https://codeberg.org/martianh/mastodon.el")
-      (synopsis "Emacs client for Mastodon")
-      (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+  (package
+    (name "emacs-mastodon")
+    (version "1.0.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://codeberg.org/martianh/mastodon.el")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bswv34r0x0a7va0qm6014zy1ddm4sv0l0k37d7z9r295kyz2v0s"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               ;; Move the source files to the top level, which is included in
+               ;; the EMACSLOADPATH.
+               (add-after 'unpack 'move-source-files
+                 (lambda _
+                   (let ((el-files (find-files "./lisp" ".*\\.el$")))
+                     (for-each (lambda (f)
+                                 (rename-file f (basename f)))
+                               el-files)))))))
+    (propagated-inputs
+     (list emacs-request emacs-ts emacs-persist))
+    (home-page "https://codeberg.org/martianh/mastodon.el")
+    (synopsis "Emacs client for Mastodon")
+    (description "@code{mastodon.el} is an Emacs client for Mastodon, the
 federated microblogging social network.")
-	  (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-ebdb
   (package