diff mbox series

[bug#39212] gnu: helm: Build vst plugin.

Message ID ae3b1802568794a75fa8fea36d7b822e5c044a37.camel@zrythm.org
State Accepted
Headers show
Series [bug#39212] gnu: helm: Build vst plugin. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Jan. 21, 2020, 4:48 a.m. UTC
Hi,

This now produces a VST plugin in addition to LV2 and standalone.

Thanks,
Alex

Comments

Alexandros Theodotou Feb. 26, 2020, 9:52 p.m. UTC | #1
Closing because we don't really need/want VST.
diff mbox series

Patch

From 112afeadec3a9ff1351334535c370e382296e58a Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 21 Jan 2020 04:34:21 +0000
Subject: [PATCH] gnu: helm: Build vst plugin.

* gnu/packages/music.scm (helm)[arguments]: Build VST plugin in addition
  to LV2 and standalone.
---
 gnu/packages/music.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ad369bd3a8..9f0e9c9fc8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5076,7 +5076,7 @@  MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
      `(#:tests? #f  ; no "check" target
        #:make-flags
        (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
-             "lv2" "standalone")
+             "lv2" "vst" "standalone")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'include-pnglib-code-and-remove-usr-from-paths
@@ -5096,6 +5096,12 @@  MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
                        (find-files (string-append (assoc-ref outputs "out"))
                                    ".*\\.gz$"))
              #t))
+         (add-after 'install 'rename-vst ; /lib/vst is the standard path
+           (lambda _
+             (let ((out (assoc-ref %outputs "out")))
+               (rename-file (string-append out "/lib/lxvst")
+                            (string-append out "/lib/vst"))
+             #t)))
          (delete 'configure))))
     (inputs
      `(("alsa-lib" ,alsa-lib)
-- 
2.24.1