[bug#75391,05/12] gnu: Add rust-fast-image-resize-5.
Commit Message
* gnu/packages/crates-graphics.scm (rust-fast-image-resize-5): New variable.
Change-Id: Ie0f755bc77ec019a0a8a8c75e1140337343acba0
---
gnu/packages/crates-graphics.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
@@ -1411,6 +1411,34 @@ (define-public rust-exr-1
(description "Read and write OpenEXR files without any unsafe code")
(license license:bsd-3)))
+(define-public rust-fast-image-resize-5
+ (package
+ (name "rust-fast-image-resize")
+ (version "5.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fast_image_resize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1qp95mkllxmkc3q0iwh1rj9cgv0rixpjz5wdw6avv2n17g090y7c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-bytemuck" ,rust-bytemuck-1)
+ ("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-document-features" ,rust-document-features-0.2)
+ ("rust-image" ,rust-image-0.25)
+ ("rust-num-traits" ,rust-num-traits-0.2)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-thiserror" ,rust-thiserror-1))))
+ (home-page "https://github.com/cykooz/fast_image_resize")
+ (synopsis
+ "Library for fast image resizing with using of SIMD instructions")
+ (description
+ "This package provides Library for fast image resizing with using of SIMD instructions.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-fast-image-resize-2
(package
(name "rust-fast-image-resize")