diff mbox series

[bug#38876] gnu: Add libmediaart. V2

Message ID aded163d3ed532fce4a387ef4b79eb014f9b60ad.camel@disroot.org
State Accepted
Headers show
Series [bug#38876] gnu: Add libmediaart. V2 | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 2, 2020, 7:58 p.m. UTC
Hello Guix!

Please find the revised patch for adding libmediaart, attached with
this email.

Regards,
RG.
diff mbox series

Patch

From c58cd6327d975cdb95aed9a6b3d7c0d660c565d2 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 2 Jan 2020 14:53:01 -0500
Subject: [PATCH] gnu: Add libmediaart.

* gnu/packages/gnome.scm (libmediaart): New variable.
---
 gnu/packages/gnome.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 036547f471..1e713d4fe1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,34 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public libmediaart
+  (package
+    (name "libmediaart")
+    (version "1.9.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0gc10imyabk57ar54m0qzms0x9dnmkymhkzyk8w1aj3y4lby0yx5"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gdk-pixbuf" ,gdk-pixbuf)
+       ("gettext" ,gettext-minimal)
+       ("gobject-introspection" ,gobject-introspection)
+       ("gtk+:doc", gtk+ "doc")
+       ("vala" ,vala)))
+    (synopsis "Media Art library for GNOME desktop")
+    (description "Library tasked with managing, extracting and
+handling media art caches.")
+    (home-page "https://gitlab.gnome.org/GNOME/libmediaart")
+    (license license:gpl2+)))
+
 (define-public gnome-menus
   (package
     (name "gnome-menus")
-- 
2.24.1