diff mbox series

[bug#72231] gnu: Add emacs-org-remark.

Message ID adea8b6eb689cc1a08e8d383eb98e33d11f543c5.1721577724.git.monego@posteo.net
State New
Headers show
Series [bug#72231] gnu: Add emacs-org-remark. | expand

Commit Message

Vinicius Monego July 21, 2024, 4:11 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-remark): New variable.

Change-Id: If7c5cca824f9b9a0c3f7fb0d39d0f73f0fe52460
---
This package was also submitted in issue 54238.

 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 81904c16aed72bb8ea1449587418d2a218d0b103

Comments

Juliana Sims July 22, 2024, 1:38 a.m. UTC | #1
Hello,

This patch looks pretty good!  Things build fine, don't break pull, 
etc. etc.  QA has a failure applying the patch, but I had no issues 
apply on top of e5c0b62debc.  There is one small issue I see: the 
description.  That "with using" bit should be cleaned up.  Also, it may 
be worthwhile to include more information.  There appears to be a 
"Features" section of the README which can provide some ideas.

Also, feel free to update your license line if you like :)

Best,
Juli

PS this new QA web interface is snazzy!  It even gave me a little 
checklist :D

Items marked as checked: Lint warnings, Package builds, Commit 
messages, New package licenses, New package tests
Vinicius Monego July 28, 2024, 3:37 p.m. UTC | #2
Em dom, 2024-07-21 às 21:38 -0400, Juliana Sims escreveu:
> Hello,
> 
> This patch looks pretty good!  Things build fine, don't break pull, 
> etc. etc.  QA has a failure applying the patch, but I had no issues 
> apply on top of e5c0b62debc.  There is one small issue I see: the 
> description.  That "with using" bit should be cleaned up.  Also, it
> may 
> be worthwhile to include more information.  There appears to be a 
> "Features" section of the README which can provide some ideas.
> 
> Also, feel free to update your license line if you like :)
> 
> Best,
> Juli
> 
> PS this new QA web interface is snazzy!  It even gave me a little 
> checklist :D
> 
> Items marked as checked: Lint warnings, Package builds, Commit 
> messages, New package licenses, New package tests
> 
> 

Hi Juli,

I applied your suggestions and pushed the patch, thanks.

Vinicius
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3f987f8ae6..12450e103f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15196,6 +15196,28 @@  (define-public emacs-centaur-tabs
 efficient tabs plugin for Emacs with a lot of customization options.")
     (license license:gpl3+)))
 
+(define-public emacs-org-remark
+  (package
+    (name "emacs-org-remark")
+    (version "1.2.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nobiot/org-remark")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1b6nmd64jzy6a7fz4x5p276sl36xa72y3ajbl72vr5ndqp94rlz1"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     (list emacs-org))
+    (home-page "https://nobiot.github.io/org-remark/")
+    (synopsis "Highlight & annotate text using Org mode")
+    (description "Org-remark lets you highlight and annotate text files,
+websites, EPUB books and Info documentation with using Org mode.")
+    (license license:gpl3+)))
+
 (define-public emacs-mocker
   (package
     (name "emacs-mocker")