diff mbox series

[bug#68908] gnu: Add ocaml-stdune.

Message ID ade1d9a963c3f0d89136c6639cc48fc774d0e0ed.1706972151.git.soeren@soeren-tempel.net
State New
Headers show
Series [bug#68908] gnu: Add ocaml-stdune. | expand

Commit Message

Sören Tempel Feb. 3, 2024, 3:12 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/ocaml.scm (ocaml-stdune): New variable.

Signed-off-by: Sören Tempel <soeren@soeren-tempel.net>
---
 gnu/packages/ocaml.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 93b38b1442..4d61610335 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8333,6 +8333,23 @@  (define-public ocaml-dyn
     (description "Dynamic type")
     (license license:expat)))
 
+(define-public ocaml-stdune
+  (package
+    (inherit dune)
+    (name "ocaml-stdune")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "stdune"
+       ;; No separate test suite from dune.
+       #:tests? #f))
+    (propagated-inputs (list ocaml-dyn ocaml-ordering ocaml-pp ocaml-csexp
+                             ocaml-odoc))
+    (synopsis "Dune's unstable standard library")
+    (description
+     "This library ships the Dune standard library, the library does not
+provide any backwards compatibility or stability guarantees.")
+    (license license:expat)))
+
 (define-public ocaml-dune-build-info
   (package
     (inherit dune)