diff mbox series

[bug#64447] gnu: python-pymol: Fix launch script.

Message ID ada8c17e2837573be015a05590fd3d55bea0d462.1688419842.git.david.elsing@posteo.net
State New
Headers show
Series [bug#64447] gnu: python-pymol: Fix launch script. | expand

Commit Message

David Elsing July 3, 2023, 9:31 p.m. UTC
* gnu/packages/chemistry.scm (python-pymol)[#:phases]: Add ‘disable-unchroot’.
[native-inputs]: Remove python-setuptools.
---
 gnu/packages/chemistry.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

Comments

Andreas Enge July 26, 2023, 2:16 p.m. UTC | #1
Applied, thanks!

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index cddccf8aea..1f8b051a85 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -6,7 +6,7 @@ 
 ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2022 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2022, 2023 David Elsing <david.elsing@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -554,6 +554,12 @@  (define-public python-pymol
                                     (assoc-ref inputs "libxml2")
                                     "/include/libxml2:"
                                     (getenv "CPLUS_INCLUDE_PATH")))))
+         ;; Prevent deleting the leading / in the __init__.py path in the
+         ;; launch script.
+         (add-after 'unpack 'disable-unchroot
+           (lambda _
+             (substitute* "setup.py"
+               (("self\\.unchroot") ""))))
          ;; The setup.py script does not support one of the Python build
          ;; system's default flags, "--single-version-externally-managed".
          (replace 'install
@@ -572,8 +578,7 @@  (define-public python-pymol
            python-pyqt
            glm
            netcdf))
-    (native-inputs
-     (list catch2 python-setuptools))
+    (native-inputs (list catch2))
     (home-page "https://pymol.org")
     (synopsis "Molecular visualization system")
     (description "PyMOL is a capable molecular viewer and renderer.  It can be