diff mbox series

[bug#66562] gnu: emacs-haskell-snippets: Fix haskell-snippets-dir value.

Message ID ad09c0c696f167a5f2ca7aa59440626953ac1e60.1697383005.git.Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#66562] gnu: emacs-haskell-snippets: Fix haskell-snippets-dir value. | expand

Commit Message

Rostislav Svoboda Oct. 15, 2023, 3:17 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): Fix
haskell-snippets-dir value

The value of haskell-snippets-dir was:
  /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-lisp/haskell-snippets-*/
It needs to be:
  /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-lisp/

The error was (abbreviated):
No such file or directory, /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-lisp/haskell-snippets-*/snippets
---
 gnu/packages/emacs-xyz.scm | 6 ++++++
 1 file changed, 6 insertions(+)


base-commit: a0d2ecde943bd1854ddbb7c0cad35a1fc64dc5ab

Comments

Liliana Marie Prikler Oct. 15, 2023, 4:01 p.m. UTC | #1
Am Sonntag, dem 15.10.2023 um 17:17 +0200 schrieb Rostislav Svoboda:
> * gnu/packages/emacs-xyz.scm (emacs-haskell-snippets): Fix
> haskell-snippets-dir value
> 
> The value of haskell-snippets-dir was:
>   /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-
> lisp/haskell-snippets-*/
> It needs to be:
>   /gnu/store/*-emacs-haskell-snippets-*/share/emacs/site-lisp/
> 
> The error was (abbreviated):
> No such file or directory, /gnu/store/*-emacs-haskell-snippets-
> */share/emacs/site-lisp/haskell-snippets-*/snippets
Explanations go above the ChangeLog.
> ---
>  gnu/packages/emacs-xyz.scm | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index bb8c25f9b5..8bb0d6d43a 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -35545,6 +35545,12 @@ (define-public emacs-haskell-snippets
>         (list
>          #:phases
>          #~(modify-phases %standard-phases
> +            (add-after 'unpack 'patch-haskell-snippets-dir
> +              (lambda* (#:key outputs #:allow-other-keys)
> +                (emacs-substitute-sexps "haskell-snippets.el"
> +                  ("setq haskell-snippets-dir"
> +                   '(file-name-parent-directory
> +                     (file-name-directory load-file-name))))))
There is actually a substitute-sexps specialization for variables. 
Perhaps use that instead?

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb8c25f9b5..8bb0d6d43a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35545,6 +35545,12 @@  (define-public emacs-haskell-snippets
        (list
         #:phases
         #~(modify-phases %standard-phases
+            (add-after 'unpack 'patch-haskell-snippets-dir
+              (lambda* (#:key outputs #:allow-other-keys)
+                (emacs-substitute-sexps "haskell-snippets.el"
+                  ("setq haskell-snippets-dir"
+                   '(file-name-parent-directory
+                     (file-name-directory load-file-name))))))
             (add-after 'install 'install-snippets
               (lambda _
                 (let ((snippets