diff mbox series

[bug#70109] gnu: dbus-for-jami: Use Gexp.

Message ID acfc5bcad4eb4ce0d14a42f4afbec88fc6aa0322.1711900722.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#70109] gnu: dbus-for-jami: Use Gexp. | expand

Commit Message

Z572 March 31, 2024, 3:58 p.m. UTC
This is a follow-up to 26485fc5750d2e067c45d49ab2aa20f481e1979a.

* gnu/packages/glib.scm(dbus-for-jami): Use Gexp.

Change-Id: I56fd25502be65ba688519dea7462c401aeddba31
---
 gnu/packages/glib.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)


base-commit: 4d79a9cd6b5f0d8c5afbab0c6b70ae42740d5470

Comments

Liliana Marie Prikler March 31, 2024, 4:04 p.m. UTC | #1
Am Sonntag, dem 31.03.2024 um 23:58 +0800 schrieb Zheng Junjie:
> This is a follow-up to 26485fc5750d2e067c45d49ab2aa20f481e1979a.
> 
> * gnu/packages/glib.scm(dbus-for-jami): Use Gexp.
There should be a space before the parenthesis and I personally prefer
to spell out G-Expression.
> 
> Change-Id: I56fd25502be65ba688519dea7462c401aeddba31
> ---
>  gnu/packages/glib.scm | 13 +++++++------
>  1 file changed, 7 insertions(+), 6 deletions(-)
> 
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index cf066a8aa6..b11046f05d 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -19,6 +19,7 @@
>  ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
>  ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
>  ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
> +;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -202,12 +203,12 @@ (define-public dbus-for-jami
>       (arguments
>        (substitute-keyword-arguments (package-arguments dbus)
>          ((#:phases phases)
> -         `(modify-phases ,phases
> -            (add-after 'unpack 'customize-config
> -              (lambda _
> -                (substitute* "bus/session.conf.in"
> -                  (("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-
> local.conf")
> -                   "/var/run/jami/session-local.conf")))))))))))
> +         #~(modify-phases #$phases
> +             (add-after 'unpack 'customize-config
> +               (lambda _
> +                 (substitute* "bus/session.conf.in"
> +                   (("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-
> local.conf")
> +                    "/var/run/jami/session-local.conf")))))))))))
Thanks for the patch, but is it critical at the moment?  As far as I
can see, jami builds without it.

Cheers
Maxim Cournoyer March 31, 2024, 5:56 p.m. UTC | #2
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Sonntag, dem 31.03.2024 um 23:58 +0800 schrieb Zheng Junjie:
>> This is a follow-up to 26485fc5750d2e067c45d49ab2aa20f481e1979a.
>> 
>> * gnu/packages/glib.scm(dbus-for-jami): Use Gexp.
> There should be a space before the parenthesis and I personally prefer
> to spell out G-Expression.
>> 
>> Change-Id: I56fd25502be65ba688519dea7462c401aeddba31
>> ---
>>  gnu/packages/glib.scm | 13 +++++++------
>>  1 file changed, 7 insertions(+), 6 deletions(-)
>> 
>> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
>> index cf066a8aa6..b11046f05d 100644
>> --- a/gnu/packages/glib.scm
>> +++ b/gnu/packages/glib.scm
>> @@ -19,6 +19,7 @@
>>  ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
>>  ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
>>  ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
>> +;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -202,12 +203,12 @@ (define-public dbus-for-jami
>>       (arguments
>>        (substitute-keyword-arguments (package-arguments dbus)
>>          ((#:phases phases)
>> -         `(modify-phases ,phases
>> -            (add-after 'unpack 'customize-config
>> -              (lambda _
>> -                (substitute* "bus/session.conf.in"
>> -                  (("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-
>> local.conf")
>> -                   "/var/run/jami/session-local.conf")))))))))))
>> +         #~(modify-phases #$phases
>> +             (add-after 'unpack 'customize-config
>> +               (lambda _
>> +                 (substitute* "bus/session.conf.in"
>> +                   (("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-
>> local.conf")
>> +                    "/var/run/jami/session-local.conf")))))))))))
> Thanks for the patch, but is it critical at the moment?  As far as I
> can see, jami builds without it.

The jami-service-type is broken I believe (it requires it).  I'll push
it shortly.

-- 
Thanks,
Maxim
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index cf066a8aa6..b11046f05d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -202,12 +203,12 @@  (define-public dbus-for-jami
      (arguments
       (substitute-keyword-arguments (package-arguments dbus)
         ((#:phases phases)
-         `(modify-phases ,phases
-            (add-after 'unpack 'customize-config
-              (lambda _
-                (substitute* "bus/session.conf.in"
-                  (("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-local.conf")
-                   "/var/run/jami/session-local.conf")))))))))))
+         #~(modify-phases #$phases
+             (add-after 'unpack 'customize-config
+               (lambda _
+                 (substitute* "bus/session.conf.in"
+                   (("@SYSCONFDIR_FROM_PKGDATADIR@/dbus-1/session-local.conf")
+                    "/var/run/jami/session-local.conf")))))))))))
 
 (define-public dbus-1.15.0
   ;; Dbus 1.15.2 has a breaking change.