diff mbox series

[bug#68084] gnu: xcb-util-render-util: Fix cross-compiling to riscv64-linux.

Message ID ace692311c3a25dda1f11326125e165cce472651.1703773369.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#68084] gnu: xcb-util-render-util: Fix cross-compiling to riscv64-linux. | expand

Commit Message

Zheng Junjie Dec. 28, 2023, 2:22 p.m. UTC
* gnu/packages/xorg.scm (xcb-util-render-util)
[native-inputs]: When cross compiling to riscv64-linux-gnu, add config.
[arguments]: When target riscv64-linux-gnu, add update-config-scripts phase.

Change-Id: I906a2b7b7691ae53592cfa35ba64fc7e7d735664
---
 gnu/packages/xorg.scm | 22 ++++++++++++++++++++--
 1 file changed, 20 insertions(+), 2 deletions(-)


base-commit: bc509aba838780502b83f7fc3d2aee72903656f2
prerequisite-patch-id: dfd1784933361e11899b06d065adaa69c6a41c85
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 382075237a..4f85a5de8b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5675,11 +5675,29 @@  (define-public xcb-util-renderutil
                "0nza1csdvvxbmk8vgv8vpmq7q8h05xrw3cfx9lwxd1hjzd47xsf6"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags '("--disable-static")))
+     `(#:configure-flags '("--disable-static")
+       ,@(if (and (%current-target-system)
+                  (target-riscv64?))
+             `(#:phases
+               (modify-phases %standard-phases
+                 (add-after 'unpack 'update-config-scripts
+                   (lambda* (#:key inputs native-inputs #:allow-other-keys)
+                     ;; Replace outdated config.guess and config.sub.
+                     (for-each (lambda (file)
+                                 (install-file
+                                  (search-input-file
+                                   (or native-inputs inputs)
+                                   (string-append "/bin/" file)) "."))
+                               '("config.guess" "config.sub"))))))
+             '())))
     (propagated-inputs
      (list libxcb))
     (native-inputs
-     (list pkg-config))
+     (append (if (and (%current-target-system)
+                      (target-riscv64?))
+                 (list config)
+                 '())
+             (list pkg-config)))
     (home-page "https://cgit.freedesktop.org/xcb/util-renderutil/")
     (synopsis "Convenience functions for the Render extension")
     (description