diff mbox series

[bug#70924,05/10] gnu: Add python-uri-template.

Message ID acdbf268e728f200c2d628c59a42d44846246d9a.1715633288.git.monego@posteo.net
State New
Headers show
Series Add some SageMath standard packages. | expand

Commit Message

Vinicius Monego May 13, 2024, 8:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-uri-template): New variable.

Change-Id: I31c110ca1581298f5648213c4247d30b156c5f77
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1bb08ecb9b..79c7b310d4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24249,6 +24249,24 @@  (define-public python-icdiff
 parts of the lines that were modified.")
     (license license:psfl)))
 
+(define-public python-uri-template
+  (package
+    (name "python-uri-template")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "uri-template" version))
+       (sha256
+        (base32 "1ixczlgnsjv2850r6w0cb2npwcwzdqri8njr1pi7v371cpmzh00f"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #f)) ; there are no Python test scripts
+    (home-page "https://gitlab.linss.com/open-source/python/uri-template")
+    (synopsis "RFC 6570 URI Template Processor")
+    (description "This packages implements URI Template expansion in strict
+adherence to RFC 6570, but adds a few extensions.")
+    (license license:expat)))
+
 (define-public python-dirsync
   (package
     (name "python-dirsync")