diff mbox series

[bug#40616] Add emacs-4clojure

Message ID acda1dd84c0396cb5d6702cedf25a2ac@posteo.net
State Accepted
Headers show
Series [bug#40616] Add emacs-4clojure | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Alberto EFG April 14, 2020, 12:47 a.m. UTC
Add emacs-4clojure

Comments

ashish.is--- via Guix-patches" via April 14, 2020, 12:55 a.m. UTC | #1
For the record (and any reviewers), these patches should be 
applied in order:

#40591 emacs-org-roam
#40593 emacs-uml-mode
#40616 emacs-4clojure
#40613 emacs-typing

They're not interdependent, just patch-context-dependent.

Kind regards,

T G-R
Nicolas Goaziou April 22, 2020, 10:13 p.m. UTC | #2
Hello,

Alberto EFG <albertoefg@posteo.mx> writes:

> Add emacs-4clojure
>
> From 510a71b4e17e8588f3e93f8735fe27b45b3e5827 Mon Sep 17 00:00:00 2001
> From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
> Date: Mon, 13 Apr 2020 02:06:27 -0500
> Subject: [PATCH] gnu: Add emacs-4clojure.
>
> * gnu/packages/emacs-xyz.scm (emacs-4clojure): New variable.

Thank you. I pushed this, as 4e74cef97a49d06c53903786bac95f510212f949.

Note that I had to fix indentation. I also added outer let-bindings for
commit and revision since there is no proper release.

> +   (description "@code{emacs-4clojure} allows you to interact with
> +@code{4clojure.com} problems, you can open an specific question and move
> +to the next or previous.  You can also verify you answers.")

I wrote instead:

    Emacs 4clojure interacts with @url{http://www.4clojure.com, 4clojure}
    problems. You can open a specific question and move to the next or
    previous one. You can also verify your answers.

Regards,
diff mbox series

Patch

From 510a71b4e17e8588f3e93f8735fe27b45b3e5827 Mon Sep 17 00:00:00 2001
From: Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
Date: Mon, 13 Apr 2020 02:06:27 -0500
Subject: [PATCH] gnu: Add emacs-4clojure.

* gnu/packages/emacs-xyz.scm (emacs-4clojure): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0fdc509038..1223eedb0c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22354,4 +22354,27 @@  and created quickly.  Org-roam should also work as a plug-and-play
  makes it easy to build ascii UML sequence diagrams in Emacs,
 which can be embedded in source code, comments or emails.")
    (license license:gpl3)))
+
+(define-public emacs-4clojure
+  (package
+   (name "emacs-4clojure")
+   (version "0.2.1")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://github.com/emacsorphanage/4clojure.git")
+           (commit "4eccf8c7d4341a36c269451838114b27836699f9")))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32
+       "19x653lzc1dxil4ix257hciidbdmbhaxhs6qhlkwi9ygjrlrgvnk"))))
+   (build-system emacs-build-system)
+   (propagated-inputs
+    `(("emacs-request" ,emacs-request)))
+   (home-page "https://github.com/emacsorphanage/4clojure")
+   (synopsis "Emacs mode to open and evaluate 4clojure.com questions")
+   (description "@code{emacs-4clojure} allows you to interact with
+@code{4clojure.com} problems, you can open an specific question and move
+to the next or previous.  You can also verify you answers.")
+   (license license:gpl3)))
-- 
2.26.0