[bug#75503,v3,3/3] gnu: Add partitionmanager.

Message ID acc4053d15ab84f957424d5677f927e14b8171ca.1736685617.git.sughosha@disroot.org
State New
Headers
Series gnu: Add partitionmanager. |

Commit Message

Sughosha Jan. 12, 2025, 12:40 p.m. UTC
  * gnu/packages/kde.scm (partitionmanager): New variable.

Change-Id: I2bd1df994274397ecd92dd78d84954d97fe75f5a
---
 gnu/packages/kde.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
  

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 9481ecd8ea..3a16c2099c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1319,6 +1319,45 @@  (define-public kpmcore
     (description "Library for managing partitions.")
     (license license:gpl3+)))
 
+(define-public partitionmanager
+  (package
+    (name "partitionmanager")
+    (version "24.05.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/partitionmanager-" version ".tar.xz"))
+       (sha256
+        (base32 "01xmwkwv8jrwx2jpg797ar8ac9gbdagrl2v3yzqn62fhwcwjcxy6"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:qtbase qtbase))
+    (native-inputs
+     (list extra-cmake-modules kdoctools))
+    (inputs
+     (list kconfig
+           kconfigwidgets
+           kcoreaddons
+           kcrash
+           kdbusaddons
+           ki18n
+           kio
+           kjobwidgets
+           kpmcore
+           kwidgetsaddons
+           kwindowsystem
+           kxmlgui
+           polkit-qt6))
+    (home-page "https://apps.kde.org/partitionmanager/")
+    (synopsis "Disk device, partition and file system manager")
+    (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems.  It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data.  It
+supports a large number of file systems, including ext2/3/4, btrfs, NTFS,
+FAT16/32, JFS, XFS and more.")
+    (license license:gpl3+)))
+
 (define-public kpublictransport
   (package
     (name "kpublictransport")