diff mbox series

[bug#65212,v2] gnu: Add cage.

Message ID acbcaedf5ded4ed50677b945a61be398b8cd77f6.1691752952.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#65212,v2] gnu: Add cage. | expand

Commit Message

Nicolas Graves Aug. 11, 2023, 11:22 a.m. UTC
* gnu/packages/wm.scm (cage): New variable.
---
 gnu/packages/wm.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: a1c1e0dd0340050964ea5a1b61738be6db8982a6

Comments

Ludovic Courtès Aug. 12, 2023, 9:13 p.m. UTC | #1
Nicolas Graves <ngraves@ngraves.fr> skribis:

> * gnu/packages/wm.scm (cage): New variable.

Tweaked the synopsis as noted by ‘guix lint’ and applied it.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8cc1f43e38..d44e791fc7 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -63,6 +63,7 @@ 
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Jonathan Brielamier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2023 Vessel Wave <vesselwave@disroot.org>
+;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -193,6 +194,27 @@  (define-public bspwm
 the leaves of a full binary tree.")
     (license license:bsd-2)))
 
+(define-public cage
+  (package
+    (name "cage")
+    (version "0.1.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cage-kiosk/cage")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256 (base32 "11sg9x08zl2nr7a723h462knz5lf58sgvkhv1mgc9z3hhkhvbsja"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config scdoc))
+    (inputs (list wayland wlroots libxkbcommon))
+    (home-page "https://github.com/cage-kiosk/cage")
+    (synopsis "A Wayland kiosk")
+    (description "This package provides a Wayland kiosk, which runs a single,
+ maximized application.")
+    (license license:expat)))
+
 (define-public herbstluftwm
   (package
     (name "herbstluftwm")