diff mbox series

[bug#62191,5/5] gnu: reuse: Update to 1.1.2.

Message ID acb998549e27f61a00b10090fb5e832f97e30477.1678818382.git.mirai@makinata.eu
State New
Headers show
Series gnu: reuse: Update to 1.1.2. | expand

Commit Message

Bruno Victal March 14, 2023, 6:27 p.m. UTC
* gnu/packages/license.scm (reuse): Update to 1.1.2.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Add python-poetry-core. Remove python-setuptools-scm.
[inputs]: Remove python-requests.
---
 gnu/packages/license.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index 3146f38c1c..ca8375d19d 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -30,6 +30,7 @@  (define-module (gnu packages license)
   #:use-module (gnu packages python-xyz)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix licenses)
@@ -169,23 +170,22 @@  (define-public licensecheck
 (define-public reuse
   (package
     (name "reuse")
-    (version "1.0.0")
+    (version "1.1.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "reuse" version))
        (sha256
-        (base32 "1m78q5x19xvhywi1xl0prrag89ihvqiq14lba27rrxl75nz24c6v"))))
-    (build-system python-build-system)
+        (base32 "0ij2mpdnawjabnsy291157wzci9050dfclwib95phg7pnmd6xsw0"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-pytest python-setuptools-scm))
+     (list python-poetry-core python-pytest))
     (inputs
      (list python-binaryornot
            python-boolean.py
            python-debian
            python-jinja2
-           python-license-expression
-           python-requests))
+           python-license-expression))
     (home-page "https://reuse.software/")
     (synopsis "Provide and verify copyright and licensing information")
     (description