diff mbox series

[bug#69352,OPTIONAL,13/13] gnu: python: python-scikit-build: Add more non-deterministic test failures.

Message ID acb4b892c05cd8cb5951c214686997350de94e54.1708771294.git.liliana.prikler@gmail.com
State New
Headers show
Series Update Clingo to 5.7.1, etc pp | expand

Commit Message

Liliana Marie Prikler Feb. 24, 2024, 9:17 a.m. UTC
* gnu/packages/python-xyz.scm (python-scikit-build)[#:phases]<check>: Also
exclude “test_cxx_compiler” and “test_fortran_compiler”.
---
This one might be a bit controversial, as I haven't reported this issue
upstream either, but I've noticed that some quite fundamental-seeming
tests fail locally.  Shouldn't happen on CI, but you never know.

 gnu/packages/python-xyz.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 88dadb9f4a..dc99588ccb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31930,7 +31930,10 @@  (define-public python-scikit-build
                               ;; nondeterministically (see:
                               ;; https://github.com/scikit-build/scikit-build/issues/711).
                               "and not test_generator_cleanup "
-                              "and not test_generator_selection ")))))
+                              "and not test_generator_selection "
+                              ;; … and there's more of them
+                              "and not test_cxx_compiler "
+                              "and not test_fortran_compiler ")))))
           (add-after 'install 'install-cmake
             (lambda* (#:key outputs #:allow-other-keys)
               (let ((lib (string-append (assoc-ref outputs "out")