diff mbox series

[bug#69074] gnu: Add python-keystone-engine.

Message ID ac6b9eca583c61e7d9a6467caf6306f77b9543b7.1707749005.git.soeren@soeren-tempel.net
State New
Headers show
Series [bug#69074] gnu: Add python-keystone-engine. | expand

Commit Message

Sören Tempel Feb. 12, 2024, 2:58 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/python-xyz.scm (python-keystone-engine): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e630bdb6a6..e4f6483f70 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32303,6 +32303,28 @@  (define-public python-opcodes
 and BMI2).")
       (license license:bsd-2))))
 
+(define-public python-keystone-engine
+  (package
+    (name "python-keystone-engine")
+    (version "0.9.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "keystone-engine" version))
+       (sha256
+        (base32 "1xahdr6bh3dw5swrc2r8kqa8ljhqlb7k2kxv5mrw5rhcmcnzcyig"))))
+    (native-inputs (list cmake))
+    (build-system pyproject-build-system)
+    (home-page "https://www.keystone-engine.org")
+    (synopsis
+     "Lightweight multi-platform, multi-architecture assembler framework")
+    (description
+     "Keystone is a lightweight multi-platform, multi-architecture
+assembler framework.  It supports a wide-range of different architectures
+and offers an intuitive architecture-neutral API for interacting with
+assembly for these architectures.")
+    (license license:gpl2)))
+
 (define-public python-itanium-demangle
   (package
     (name "python-itanium-demangle")