From a6f67e7f17b8924d928f26caca70d0b7ddfc5a04 Mon Sep 17 00:00:00 2001
From: Roman Riabenko <roman@riabenko.com>
Date: Mon, 11 Apr 2022 13:27:08 +0300
Subject: [PATCH] gnu: games: Add robotfindskitten.
* gnu/packages/games.scm (robotfindskitten): New variable.
---
gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -69,6 +69,7 @@
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2250,6 +2251,36 @@ (define-public retux
license:gpl2+
license:gpl3+)))))
+(define-public robotfindskitten
+ (package
+ (name "robotfindskitten")
+ (version "2.8284271.702") ; 1600003_201b is older, see ChangeLog
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/" name "/" name
+ "/releases/download/" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bwrkxm83r9ajpkd6x03nqvmdfpf5vz6yfy0c97pq3v3ykj74082"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ; there are no tests
+ #:make-flags
+ #~(list "CFLAGS=-D_XOPEN_SOURCE=600" ; http://bugs.gnu.org/54607
+ (string-append "execgamesdir=" #$output "/bin")))) ; /games
+ (inputs (list ncurses))
+ (outputs (list "out" "debug"))
+ (synopsis "Thematic meditative game for terminals")
+ (description
+ "Play for a robot in a realm appearing as a rectangle filled with ASCII
+characters. Move with determination to find the kitten while examining useless
+items with often amusing descriptions and thus experience this \"Zen
+simulation.\" The theme of the game continues in its documentation. You can
+also replace the descriptions of the items with a custom file.")
+ (home-page "http://robotfindskitten.org/")
+ (license license:gpl2+)))
+
(define-public roguebox-adventures
(package
(name "roguebox-adventures")
base-commit: 7da907f90e74a4edf96d76ee457ff958265ef8d4
--
2.35.1