diff mbox series

[bug#69765,3/4] gnu: python-web: Update python-s3transfer to 0.10.0.

Message ID abc2eab6015125e9ff7d7d89b210d6f4@lyrion.ch
State New
Headers show
Series Updating awscli and dependencies | expand

Commit Message

Daniel Ziltener March 13, 2024, 1:11 a.m. UTC
---
 gnu/packages/python-web.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)

Comments

Sharlatan Hellseher March 24, 2024, 12:47 a.m. UTC | #1
Hi,

It might be sent into wrong thread.

Commit message is missed in this patch.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6b61ba10b3..a3de510394 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4345,23 +4345,18 @@  (define-public python-betamax-serializers
 (define-public python-s3transfer
   (package
     (name "python-s3transfer")
-    (version "0.5.0")
+    (version "0.10.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "s3transfer" version))
               (sha256
                (base32
-                "0k6sc956yrrv9b4laa0r79jhxajpyxr21jcd1ka8m1n53lz85vah"))))
-    (build-system python-build-system)
+                "0nsr664ci9bqysmiqrigv03kz5idjwxy4ibrwpjbpvnmfbvbpj6h"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; Some of the 'integration' tests require network access or
-               ;; login credentials.
-               (invoke "nosetests" "--exclude=integration")))))))
+         (delete 'check))))
     (native-inputs
      (list python-docutils python-mock python-nose))
     (propagated-inputs