diff mbox series

[bug#72014] gnu: go-github-com-ipfs-go-ipfs-cmdkit-files: Build on more systems.

Message ID ab9e1b99a5a43af6cfeceb03e8d3c411bc440007.1720541114.git.efraim@flashner.co.il
State New
Headers show
Series [bug#72014] gnu: go-github-com-ipfs-go-ipfs-cmdkit-files: Build on more systems. | expand

Commit Message

Efraim Flashner July 9, 2024, 4:05 p.m. UTC
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-cmdkit-files)
[arguments]: When building on systems which don't support go-1.16 use
gccgo-11.

Change-Id: I0cf1e3a429603dde3a7dc75f4088c5b5f62ebad4
---
 gnu/packages/ipfs.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)


base-commit: 395a3a3b003f219beb33ed2539ff0a8a35502b59

Comments

Sharlatan Hellseher July 11, 2024, 6:33 p.m. UTC | #1
Hi Efraim,

I'm about to push major update to go-team branch swapping default go to
go-1.18 or even to go-1.21 as 1.17 (02 Aug 2022), 1.18 (01 Feb 2023),
1.19 (06 Sep 2023) and 1.20 (06 Feb 2024) are EOL already
<https://endoflife.date/go>.

I've removed all #:go entries from each package where it's 1.16-1.18.

Will changing default go version solve compiling on wider range of
system?

Thanks,
Oleg
Efraim Flashner July 11, 2024, 6:52 p.m. UTC | #2
On Thu, Jul 11, 2024 at 07:33:39PM +0100, Sharlatan Hellseher wrote:
> 
> Hi Efraim,
> 
> I'm about to push major update to go-team branch swapping default go to
> go-1.18 or even to go-1.21 as 1.17 (02 Aug 2022), 1.18 (01 Feb 2023),
> 1.19 (06 Sep 2023) and 1.20 (06 Feb 2024) are EOL already
> <https://endoflife.date/go>.

Thank you for working on this!

> I've removed all #:go entries from each package where it's 1.16-1.18.
> 
> Will changing default go version solve compiling on wider range of
> system?

AFAIK the one entry of go-1.16 is the only package we have which fails
to build with go-1.17 or later.

I believe the only Guix supported systems which aren't supported by go
itself are powerpc-linux (32-bit) and i586-gnu. gccgo has been "stuck"
on go-1.18 compatibility for a number of releases, as seen in gcc.scm,
but don't let that discourage you from choosing a newer version of go as
the default.

If this patch is obsoleted by the changes you're making then feel free
to drop it. I didn't actually have a use-case for this package anyway, I
was just trying to make more packages build.
Sharlatan Hellseher July 18, 2024, 10:13 p.m. UTC | #3
Pushed as 1aa8dfaeec3c6e4e587aadf7440246f7c5c04b9f to master.
diff mbox series

Patch

diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index daf68903c2..ab7cfb53ad 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -29,6 +29,7 @@  (define-module (gnu packages ipfs)
   #:use-module (guix git-download)
   #:use-module (guix download)
   #:use-module (guix build-system go)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages golang-build)
   #:use-module (gnu packages golang-check)
@@ -150,7 +151,9 @@  (define-public go-github-com-ipfs-go-ipfs-cmdkit-files
               "0qk6fshgdmhp8dip2ksm13j6nywi41m9mn0czkvmw6b697z85l2r"))))
       (build-system go-build-system)
       (arguments
-       `(#:go ,go-1.16
+       `(#:go ,@(if (supported-package? go-1.16)
+                    `(,go-1.16)
+                    `(,gccgo-11))
          #:unpack-path "github.com/ipfs/go-ipfs-cmdkit"
          #:import-path "github.com/ipfs/go-ipfs-cmdkit/files"))
       (home-page "https://github.com/ipfs/go-ipfs-cmdkit")