[bug#76862,2/6] gnu: Add naett.

Message ID ab67825577d7028679c2dab61e62731316376b63.1741431068.git.iyzsong@member.fsf.org
State New
Headers
Series Add tic80 |

Commit Message

King, Spencer via Guix-patches" via March 8, 2025, 10:55 a.m. UTC
  From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/networking.scm (naett): New variable.

Change-Id: I5e4698d9dfe5677d945bede462943576fcfe3b06
---
 gnu/packages/networking.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
  

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b0a0fb420d..673b77585d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -89,6 +89,7 @@  (define-module (gnu packages networking)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
@@ -4292,6 +4293,38 @@  (define-public batctl
 module @code{batman-adv}, for Layer 2.")
    (license license:gpl2+)))
 
+(define-public naett
+  (package
+    (name "naett")
+    (version "0.3.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/erkkah/naett")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1nnnps1755h8yawzpf71fm4g2hqdja4zw993ilsaad3z7p464q47"))))
+    (build-system copy-build-system)
+    (inputs (list curl))
+    (arguments
+     (list #:install-plan
+           #~'(("naett.h" "include/")
+               ("libnaett.so" "lib/"))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'install 'build
+                 (lambda _
+                   (invoke #$(cc-for-target)
+                           "-o" "libnaett.so"
+                           "-shared" "-fPIC" "-O2" "naett.c"
+                           "-lcurl" "-lpthread"))))))
+    (synopsis "Tiny HTTP client library")
+    (home-page "https://github.com/erkkah/naett")
+    (description "This package provides a tiny HTTP client library in C.")
+    (license license:unlicense)))
+
 (define-public pagekite
   (package
     (name "pagekite")