[bug#76480,43/51] gnu: Add python-lofar-h5plot.

Message ID ab44ab38ef13009f39bac0a536bd82f82feedc93.1740173176.git.sharlatanus@gmail.com
State New
Headers
Series Astro update 2025/02 |

Commit Message

Sharlatan Hellseher Feb. 21, 2025, 9:49 p.m. UTC
  * gnu/packages/astronomy.scm (python-lofar-h5plot): New variable.

Change-Id: I4d780726b242cf4055fb82ef26ad97abf3419ce9
---
 gnu/packages/astronomy.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
  

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ae1030b922a..ce8a1291c4c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3051,6 +3051,37 @@  (define-public python-holodeck
 observationally-derived galaxy merger catalogs.")
     (license license:expat)))
 
+(define-public python-lofar-h5plot
+  (package
+    (name "python-lofar-h5plot")
+    (version "2.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "lofar_h5plot" version))
+       (sha256
+        (base32 "0gxri18iqsw1l5zxn40475zj34h5nn1bscfrhkc739vpqjmj60hz"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f)) ; no tests provided
+    (native-inputs
+     (list python-cython-3
+           python-setuptools
+           python-wheel))
+    (propagated-inputs
+     (list python-losoto
+           python-matplotlib
+           python-numpy
+           python-pyqt
+           python-pyqt5-sip))
+    (home-page "https://github.com/tikk3r/lofar-h5plot")
+    (synopsis "GUI for plotting H5Parms produced during LOFAR calibration")
+    (description
+     "H5plot is a small GUI to view the solutions in an H5parm interactively.
+It is a spiritual successor to @code{ParmDBplot} for quickly reviewing gain
+solutions generated by NDPPP.")
+    (license license:gpl3)))
+
 (define-public python-losoto
   (package
     (name "python-losoto")