diff mbox series

[bug#64201,15/20] gnu: python-reproject: Update to 0.11.0.

Message ID ab3780c865a3c93a0511ace1762e2dabc2c665cf.1687302523.git.sharlatanus@gmail.com
State New
Headers show
Series gnu: monthly astronomy packages update | expand

Commit Message

Sharlatan Hellseher June 21, 2023, 6:33 a.m. UTC
* gnu/packages/astronomy.scm (python-reproject): Update to 0.11.0.
[native-inputs]: Move python-pyvo, python-gwcs, python-shapely from here ...
[propagated-inputs]: ... to here. Add python-click, python-cloudpickle,
python-dask, python-fsspec, python-zarr.
---
 gnu/packages/astronomy.scm | 25 +++++++++++++++----------
 1 file changed, 15 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 514aa53258..4ba1f2eab9 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1945,13 +1945,13 @@  (define-public python-regions
 (define-public python-reproject
   (package
     (name "python-reproject")
-    (version "0.10.0")
+    (version "0.11.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "reproject" version))
        (sha256
-        (base32 "1ha0a1ja7k09ysd05adffgsapfwzc6m6az34a0av2mhmlwy4zb1q"))))
+        (base32 "0p07qlqinb826m4n5b5invyfyv4z750sai2caqaf598mgj04l61p"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -1974,21 +1974,26 @@  (define-public python-reproject
             (lambda _
               (setenv "HOME" (getcwd)))))))
     (propagated-inputs
-     (list python-astropy
+     (list python-asdf
+           python-astropy
            python-astropy-healpix
+           python-click
+           python-cloudpickle
+           python-dask
+           python-fsspec
+           python-gwcs
            python-numpy
-           python-scipy))
+           python-pyvo
+           python-scipy
+           python-shapely
+           python-zarr))
     (native-inputs
-     (list python-asdf
-           python-cython
+     (list python-cython
            python-extension-helpers
-           python-gwcs
            python-pytest-astropy
-           python-pyvo
            python-semantic-version
            python-pytest
-           python-setuptools-scm
-           python-shapely))
+           python-setuptools-scm))
     (home-page "https://reproject.readthedocs.io")
     (synopsis "Astronomical image reprojection in Python")
     (description