diff mbox series

[bug#64116] gnu: libx11: Replace with 1.8.6 [security and bug fixes]

Message ID ab3360296e0d6eb7b903365f9b8bb319c8d46401.1686941245.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#64116] gnu: libx11: Replace with 1.8.6 [security and bug fixes] | expand

Commit Message

Kaelyn Takata June 16, 2023, 6:47 p.m. UTC
Includes fix for: CVE-2023-3138.

* gnu/packages/xorg.scm (libx11-fixed): New variable.
(libx11)[replacement]: Graft.
---
 gnu/packages/xorg.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)


base-commit: 31336e9f5d68512a9c1c6826bce9f17c892a2125
--
2.40.1

Comments

Maxim Cournoyer Sept. 2, 2023, 6:49 p.m. UTC | #1
Hi,

Kaelyn Takata <kaelyn.alexi@protonmail.com> writes:

> Includes fix for: CVE-2023-3138.
>
> * gnu/packages/xorg.scm (libx11-fixed): New variable.
> (libx11)[replacement]: Graft.

Installed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index e1a7cf96f9..49a70b1e07 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5254,6 +5254,7 @@  (define-public libx11
   (package
     (name "libx11")
     (version "1.8.1")
+    (replacement libx11-fixed) ; security fixes
     (source
      (origin
        (method url-fetch)
@@ -5283,6 +5284,19 @@  (define-public libx11
     (description "Xorg Core X11 protocol client library.")
     (license license:x11)))

+(define-public libx11-fixed
+  (package
+    (inherit libx11)
+    (version "1.8.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://xorg/individual/lib/libX11-"
+                           version ".tar.xz"))
+       (sha256
+        (base32
+         "1jawl8zp1h7hdmxx1sc6kmxkki187d9yixr2l03ai6wqqry5nlsr"))))))
+
 ;; packages of height 5 in the propagated-inputs tree

 (define-public libxcursor