diff mbox series

[bug#55063] gnu: Add python-flake8-bandit and upgrade python-bandit

Message ID ab2d6404b6a74677a92af80968cd8342658ffd53.camel@adair.no
State New
Headers show
Series [bug#55063] gnu: Add python-flake8-bandit and upgrade python-bandit | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Allan Adair April 22, 2022, 9:46 a.m. UTC
* gnu/packages/python-xyz.scm (python-flake8-bandit): New variable.
* gnu/packages/openstack.scm (python-bandit): Upgrade to 1.7.4.
diff mbox series

Patch

diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 4c28bb9283..67c8b2b5b7 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2022 Allan Adair <allan@adair.no>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -49,14 +50,14 @@  (define-module (gnu packages openstack)
 (define-public python-bandit
   (package
     (name "python-bandit")
-    (version "1.6.2")
+    (version "1.7.4")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "bandit" version))
        (sha256
         (base32
-         "0rb034c99pyhb4a60z7f2kz40cjydhm8m9v2blaal1rmhlam7rs1"))))
+         "1lkvf5ffdqa9504mm5fd9vvq0q5wdyqbkm32i4rswys1fg2shqrd"))))
     (build-system python-build-system)
     (arguments
      ;; The tests are disabled to avoid a circular dependency with
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a5d311680..b45e8bc959 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,6 +119,7 @@ 
 ;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Allan Adair <allan@adair.no>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10604,6 +10605,27 @@  (define-public python-flake8-3.8
      (list python-pycodestyle-2.6 python-entrypoints python-pyflakes-2.2
            python-mccabe))))
 
+(define-public python-flake8-bandit
+  (package
+    (name "python-flake8-bandit")
+    (version "3.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "flake8_bandit" version))
+        (sha256
+          (base32 "18fnw8c0w3ij0fc4bwvmd62jvhm7q10ihbmhlwi07md8wqkr9lal"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      (list python-bandit
+            python-flake8
+            python-flake8-polyfill
+            python-pycodestyle))
+    (home-page "https://github.com/tylerwince/flake8-bandit")
+    (synopsis "Automated security testing with bandit and flake8.")
+    (description "Automated security testing with bandit and flake8.")
+    (license license:expat)))
+
 (define-public python-flake8-bugbear
   (package
     (name "python-flake8-bugbear")