diff mbox series

[bug#53434] Patches to unbreak many i686 packages

Message ID ab2a85ef9876e2292a069fe02c5d93030f38ac24.camel@telenet.be
State Accepted
Headers show
Series [bug#53434] Patches to unbreak many i686 packages | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M Feb. 18, 2022, 7:50 a.m. UTC
Ludovic Courtès schreef op do 17-02-2022 om 11:40 [+0100]:
> Yes, we can do that on master.  Do you want to give it a try?

See attachment! I verified that:

* upower builds: ./pre-inst-env guix build upower
* upower builds on i686:
 ./pre-inst-env guix build upower --system=i686-linux
* linting (almost) succeeds:

  ./pre-inst-env guix lint upower umockdev
  [...] upower@0.99.15: label 'glib' does not match package name 'glib:bin'

  I just did `(,glib "bin") (new-input style), so this seems more a problem
  of the linter or whatever code is reponsible for constructing labels to me.

  [...]: upower@0.99.15: line 5457 is way too long (101 characters)

  It contains a long URL, so not much that can be done here.

* the dependents of upower and umockdev build:

  ./pre-inst-env guix refresh -l upower umockdev
  [...]: thermald@2.4.7 gnome-power-manager@3.32.0 rhythmbox@3.4.4 eiciel@0.9.13.1 gnome-tweaks@40.0 gpaste@3.42.2 gnome-shell-extension-gsconnect@33 arc-theme@20210412 numix-gtk-theme@2.6.7 gnome@41.0 eolie@0.9.101 wmbattery@2.54 mate@1.24.1 mixxx@2.3.2 xfce@4.16.0 usbguard@0.7.8
  ./pre-inst-env guix build thermald@2.4.7 gnome-power-manager@3.32.0 rhythmbox@3.4.4 eiciel@0.9.13.1 gnome-tweaks@40.0 gpaste@3.42.2 gnome-shell-extension-gsconnect@33 arc-theme@20210412 numix-gtk-theme@2.6.7 gnome@41.0 eolie@0.9.101 wmbattery@2.54 mate@1.24.1 mixxx@2.3.2 xfce@4.16.0 usbguard@0.7.8

  This took to long to run it to the end, but no build failures so far

It has _not_ been verified whether this upower is usable for system services!

Some remarks:

* "guix refresh -u upower" did not work completely because the 'commit' field
  was

 (string-append "UPOWER_" (string-map (match-lambda (#\. #\_)
                                        (chr chr))
                                      version))

  before the update and (string-append "v" version) after the update,
  which (guix upstream) does not not how to change.

  If the tag was replaced by the commit it referred to, this would not
  have been necessary.

Greetings,
Maxime.

Comments

Ludovic Courtès Feb. 18, 2022, 1:43 p.m. UTC | #1
Hi Maxime,

Maxime Devos <maximedevos@telenet.be> skribis:

> Ludovic Courtès schreef op do 17-02-2022 om 11:40 [+0100]:
>> Yes, we can do that on master.  Do you want to give it a try?
>
> See attachment! I verified that:

Wonderful.  I pushed the whole series:

  0d1a6cffaf gnu: upower: Remove obsolete phase
  4262919ea9 gnu: umockdev: Reference libumockdev by absolute path.
  569d7ba38c gnu: umockdev: Reference 'env' and 'sh' by absolute path.
  33f2e862c7 gnu: umockdev: Use G-expressions.
  b3d7eae08e gnu: upower: Update to 0.99.15.
  7168148abe gnu: upower: Make it auto-updatable.

Thank you!

Ludo’.
diff mbox series

Patch

From 3771de31fc23a626eebb153589ceac4aa25189f6 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Thu, 17 Feb 2022 19:05:26 +0000
Subject: [PATCH 6/6] gnu: upower: Remove obsolete phase

Now umockdev-wrapper refers to things by absolute path, this phase
is no longer necessary.

* gnu/packages/gnome.scm
  (upower)[arguments]<#:phases>{pre-check}: Remove.
---
 gnu/packages/gnome.scm | 7 -------
 1 file changed, 7 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 64571d414a..708542ccd7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5469,13 +5469,6 @@  faster results and to avoid unnecessary server load.")
     (arguments
       (list
        #:glib-or-gtk? #t
-       #:phases
-       #~(modify-phases %standard-phases
-          (add-before 'check 'pre-check
-            (lambda* (#:key inputs #:allow-other-keys)
-              (let ((umockdev (string-append (assoc-ref inputs "umockdev")
-                                             "/lib")))
-                (setenv "LD_LIBRARY_PATH" umockdev)))))
        #:configure-flags
        #~(list "-Dsystemdsystemunitdir=no"
                ;; If not specified, udev will try putting history information
-- 
2.30.2