[bug#77236] gnu: nvc: Update to 1.15.2.
Commit Message
* gnu/packages/fpga.scm (nvc): Update to 1.15.2.
Change-Id: I160e0927b28efc980e9b7ce4aae9466dbabb1666
---
- update
- enable tcl support
- enable coverage support
gnu/packages/fpga.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)
base-commit: cd3a45a5eca855f43ee3520d07f4ab560daa98c6
--
2.49.0
Comments
Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:
> * gnu/packages/fpga.scm (nvc): Update to 1.15.2.
>
> Change-Id: I160e0927b28efc980e9b7ce4aae9466dbabb1666
> ---
>
> - update
> - enable tcl support
> - enable coverage support
>
> gnu/packages/fpga.scm | 8 +++++---
> 1 file changed, 5 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
> index 28ddfb42d4..f015a27417 100644
> --- a/gnu/packages/fpga.scm
> +++ b/gnu/packages/fpga.scm
> @@ -521,7 +521,7 @@ (define-public python-vunit
> (define-public nvc
> (package
> (name "nvc")
> - (version "1.15.1")
> + (version "1.15.2")
> (source (origin
> (method git-fetch)
> (uri (git-reference
> @@ -530,11 +530,11 @@ (define-public nvc
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "1hqkgwkvflha1fpch13byb8clwa97n6z1d9a2d34cqzsjrzkdx0k"))))
> + "1r6ba5jw4ja0hv366686d8haakm57h3fl95w81hda8haq6g0dj0q"))))
> (build-system gnu-build-system)
> (arguments
> (list #:out-of-source? #t
> - #:configure-flags #~(list "--enable-vhpi")
> + #:configure-flags #~(list "--enable-vhpi" "--enable-tcl" "--enable-gcov")
> #:phases #~(modify-phases %standard-phases
> (add-after 'unpack 'clean-up
> (lambda _
> @@ -552,6 +552,8 @@ (define-public nvc
> (list elfutils
> llvm-9
The minimum supported LLVM version is 8.0. Versions between 8 and 18 have all been tested.
Can we use the default llvm or newer llvm here?
> libffi
> + readline
> + tcl
> `(,zstd "lib")))
> (synopsis "VHDL compiler and simulator")
> (description "This package provides a VHDL compiler and simulator.")
>
> base-commit: cd3a45a5eca855f43ee3520d07f4ab560daa98c6
>> @@ -552,6 +552,8 @@ (define-public nvc
>> (list elfutils
>> llvm-9
>
> The minimum supported LLVM version is 8.0. Versions between 8 and 18 have all been
> tested.
>
> Can we use the default llvm or newer llvm here?
Sure ! Good catch.
@@ -521,7 +521,7 @@ (define-public python-vunit
(define-public nvc
(package
(name "nvc")
- (version "1.15.1")
+ (version "1.15.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -530,11 +530,11 @@ (define-public nvc
(file-name (git-file-name name version))
(sha256
(base32
- "1hqkgwkvflha1fpch13byb8clwa97n6z1d9a2d34cqzsjrzkdx0k"))))
+ "1r6ba5jw4ja0hv366686d8haakm57h3fl95w81hda8haq6g0dj0q"))))
(build-system gnu-build-system)
(arguments
(list #:out-of-source? #t
- #:configure-flags #~(list "--enable-vhpi")
+ #:configure-flags #~(list "--enable-vhpi" "--enable-tcl" "--enable-gcov")
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'clean-up
(lambda _
@@ -552,6 +552,8 @@ (define-public nvc
(list elfutils
llvm-9
libffi
+ readline
+ tcl
`(,zstd "lib")))
(synopsis "VHDL compiler and simulator")
(description "This package provides a VHDL compiler and simulator.")