diff mbox series

[bug#57431,v2,3/3] gnu: Add python-pyqtwebengine, version 6.6.0.

Message ID ab036c068db5a317525fdc19989d44e00f110a14.1700724016.git.herman@rimm.ee
State New
Headers show
Series [bug#57431,v2,1/3] gnu: Add python-pyqt6-sip. | expand

Commit Message

Herman Rimm Nov. 23, 2023, 7:20 a.m. UTC
From: Zhu Zihao <all_but_last@163.com>

* gnu/packages/qt.scm (python-pyqtwebengine-6): New variable.
---
 gnu/packages/qt.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 22569f5f75..6ac6afba6e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3792,6 +3792,39 @@  (define-public python-pyqtwebengine
 itself.")
     (license license:gpl3)))
 
+(define-public python-pyqtwebengine-6
+  (package
+    (inherit python-pyqtwebengine)
+    (version "6.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PyQt6_WebEngine" version))
+       (sha256
+        (base32 "11wlnggs5vi7z465xhmnz664wbaj44ki6mmijbk0kr457x69h2ym"))))
+    (native-inputs (list python python-sip python-pyqt-builder
+                         ;; qtbase is required for qmake
+                         qtbase))
+    (inputs (list python-pyqt-6 qtbase qtdeclarative qtwebchannel qtwebengine))
+    (arguments
+     (list
+      #:tests? #f ;No tests.
+      #:configure-flags #~`(@ ("--verbose" . "") ;Print commands run.
+                              ("--jobs" unquote
+                               (number->string (parallel-job-count))))
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'set-include-dirs
+                     (lambda* (#:key inputs outputs #:allow-other-keys)
+                       (let* ((version (python-version (assoc-ref inputs "python")))
+                              (sip-include-dirs (search-input-directory inputs
+                                                 (string-append "/lib/python" version
+                                                                "/site-packages/PyQt6/bindings"))))
+                         (setenv "SIP_INCLUDE_DIRS" sip-include-dirs)))))))
+    (description
+     "PyQtWebEngine is a set of Python bindings for The Qt Company's Qt
+WebEngine libraries.  The bindings sit on top of PyQt6 and are implemented as a
+set of three modules.")))
+
 (define-public python-pyqt-builder
   (package
    (name "python-pyqt-builder")