[bug#78281] gnu: ddcci-driver-linux: Fix build.

Message ID aadfe5e2871ff6390854ca98ca6b60ad234f4e09.1746547829.git.sergio.pastorperez@gmail.com
State New
Headers
Series [bug#78281] gnu: ddcci-driver-linux: Fix build. |

Commit Message

Sergio Pastor Pérez May 6, 2025, 4:10 p.m. UTC
  * gnu/packages/linux.scm (ddcci-driver-linux): Version 0.4.5 is incompatible
with linux-libre@6.14.4.

Change-Id: I8a6bed599c5730334ab672172d03d7a7c9cc757b
---
 gnu/packages/linux.scm | 74 ++++++++++++++++++++++--------------------
 1 file changed, 38 insertions(+), 36 deletions(-)


base-commit: 9f7f05e11f3319e91b21f0633532f153386996ff
  

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5903d4e7c1..2cafbd4af1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2269,47 +2269,49 @@  (define-public bin-graph
       (license license:gpl3))))
 
 (define-public ddcci-driver-linux
-  (package
-    (name "ddcci-driver-linux")
-    (version "0.4.5")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux.git")
-         (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0j2bgzadrbcyf3k4zplv7p5yqb9pw2ca6wzkqjhhidaah2722vlf"))))
-    (build-system linux-module-build-system)
-    (arguments
-     (list #:tests? #f                  ; no tests
-           #:phases
-           #~(modify-phases %standard-phases
-               (replace 'build
-                 (lambda args
-                   (for-each
-                    (lambda (module)
-                      (with-directory-excursion module
-                        (apply (assoc-ref %standard-phases 'build) args)))
-                    '("ddcci" "ddcci-backlight"))))
-               (replace 'install
-                 (lambda args
-                   (for-each
-                    (lambda (module)
-                      (with-directory-excursion module
-                        (apply (assoc-ref %standard-phases 'install) args)))
-                    '("ddcci" "ddcci-backlight")))))))
-    (home-page "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux")
-    (synopsis "Pair of Linux kernel drivers for DDC/CI monitors")
-    (description "This package provides two Linux kernel drivers, ddcci and
+  (let ((revision "0")
+        (commit "7f8f8e6c221a286d57a643c2909109a54e084eed"))
+    (package
+      (name "ddcci-driver-linux")
+      (version (git-version "0.4.5" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux.git")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0sgldghd8n4qjm5nv9dgxjibj1hg4kkk1811wndf3vx3dacsmkl9"))))
+      (build-system linux-module-build-system)
+      (arguments
+       (list #:tests? #f                  ; no tests
+             #:phases
+             #~(modify-phases %standard-phases
+                 (replace 'build
+                   (lambda args
+                     (for-each
+                      (lambda (module)
+                        (with-directory-excursion module
+                          (apply (assoc-ref %standard-phases 'build) args)))
+                      '("ddcci" "ddcci-backlight"))))
+                 (replace 'install
+                   (lambda args
+                     (for-each
+                      (lambda (module)
+                        (with-directory-excursion module
+                          (apply (assoc-ref %standard-phases 'install) args)))
+                      '("ddcci" "ddcci-backlight")))))))
+      (home-page "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux")
+      (synopsis "Pair of Linux kernel drivers for DDC/CI monitors")
+      (description "This package provides two Linux kernel drivers, ddcci and
 ddcci-backlight, that allows the control of DDC/CI monitors through the sysfs
 interface.  The ddcci module creates a character device for each DDC/CI
 monitors in @file{/dev/bus/ddcci/[I²C busnumber]}.  While the ddcci-backlight
 module allows the control of the backlight level or luminance property when
 supported under @file{/sys/class/backlight/}.")
-    (license license:gpl2+)))
+      (license license:gpl2+))))
 
 (define-public v4l2loopback-linux-module
   (package