diff mbox series

[bug#64060] gnu: emacs-gptel: Add optional propagated-input.

Message ID aaa6687b9b36351515fbfd32e652f2dc03b9d935.1686713881.git.jgart@dismail.de
State New
Headers show
Series [bug#64060] gnu: emacs-gptel: Add optional propagated-input. | expand

Commit Message

jgart June 14, 2023, 3:41 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-gptel): Add optional propagated-input.
[propagated-inputs]: Add emacs-markdown-mode
---

hi guix wdyt

what should we do about dependencies like this that are optional
according to upstream but might enable important features in a package
like markdown rendering.

l8terzzz,

jgart

 gnu/packages/emacs-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)


base-commit: b94cbbbce70f59b795526a0ed305facf041e6faa
prerequisite-patch-id: 955d53943a944fc71068775e0535d85c0f0b71ec
prerequisite-patch-id: b40ddb3f1c2f780c18f34b826b1229bb10358ec7
prerequisite-patch-id: 35ea140df746960cf9b020cb8abb74e6889b056c

Comments

Andrew Tropin June 14, 2023, 5:46 a.m. UTC | #1
On 2023-06-13 22:41, jgart wrote:

> * gnu/packages/emacs-xyz.scm (emacs-gptel): Add optional propagated-input.
> [propagated-inputs]: Add emacs-markdown-mode
> ---
>
> hi guix wdyt
>
> what should we do about dependencies like this that are optional
> according to upstream but might enable important features in a package
> like markdown rendering.
>
> l8terzzz,
>
> jgart
>
>  gnu/packages/emacs-xyz.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index f46af73aec..32ab18bd81 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -477,7 +477,8 @@ (define-public emacs-gptel
>                (emacs-substitute-variables "gptel.el"
>                  ("gptel-use-curl" 't)))))))
>      (inputs (list curl))
> -    (propagated-inputs (list emacs-map))
> +    (propagated-inputs
> +     (list emacs-map emacs-markdown-mode))
>      (home-page "https://github.com/karthink/gptel")
>      (synopsis "GPTel is a simple ChatGPT client for Emacs")
>      (description
>
> base-commit: b94cbbbce70f59b795526a0ed305facf041e6faa
> prerequisite-patch-id: 955d53943a944fc71068775e0535d85c0f0b71ec
> prerequisite-patch-id: b40ddb3f1c2f780c18f34b826b1229bb10358ec7
> prerequisite-patch-id: 35ea140df746960cf9b020cb8abb74e6889b056c

IMHO, optional dependencies in most cases should not be propagated by
the package, to make it possible to manage them on the user side in a
more flexible way.

Closing this ticket without merging, let me know if you have other
thoughts or opinions on the topic.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f46af73aec..32ab18bd81 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -477,7 +477,8 @@  (define-public emacs-gptel
               (emacs-substitute-variables "gptel.el"
                 ("gptel-use-curl" 't)))))))
     (inputs (list curl))
-    (propagated-inputs (list emacs-map))
+    (propagated-inputs
+     (list emacs-map emacs-markdown-mode))
     (home-page "https://github.com/karthink/gptel")
     (synopsis "GPTel is a simple ChatGPT client for Emacs")
     (description